summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-08-03 10:39:46 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-08-03 10:43:08 +0200
commit419315d4e6445c97a2578df4fbaa2e7594e11cf0 (patch)
tree9d1cc5d747b0fd4306dc4e1a97bab5cb835a9fe3 /gnu
parenteb632a28db27ea4a46301229ca330c56267ffe0a (diff)
downloadguix-patches-419315d4e6445c97a2578df4fbaa2e7594e11cf0.tar
guix-patches-419315d4e6445c97a2578df4fbaa2e7594e11cf0.tar.gz
gnu: Add r-stringfish.
* gnu/packages/cran.scm (r-stringfish): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 8bc6acdd02..fb6c28faa6 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -29986,3 +29986,29 @@ Apache2.")
the @code{raster} package that is suitable for extracting raster values using
@code{sf} polygons.")
(license license:asl2.0)))
+
+(define-public r-stringfish
+ (package
+ (name "r-stringfish")
+ (version "0.15.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "stringfish" version))
+ (sha256
+ (base32
+ "0m8485p1gb5z2n2g5nyr38zixw4iv8xxm7bxspxlxvx6alhn03pn"))))
+ (properties `((upstream-name . "stringfish")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-rcpp" ,r-rcpp)
+ ("r-rcppparallel" ,r-rcppparallel)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/traversc/stringfish")
+ (synopsis "Alternative string implementation")
+ (description
+ "This package provides an extendable, performant and multithreaded
+@code{alt-string} implementation backed by C++ vectors and strings.")
+ (license license:gpl3)))