summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2015-06-21 16:31:27 +1000
committerMark H Weaver <mhw@netris.org>2015-06-21 03:30:40 -0400
commit12b04cbee6b9c725db8a5c898b597de8e667bef0 (patch)
treeed8e4bd5f76f1359e46e56473339d98db05aa10d /gnu
parent407838510d39ee4b76160f5b553a3581b00f5c01 (diff)
downloadguix-patches-12b04cbee6b9c725db8a5c898b597de8e667bef0.tar
guix-patches-12b04cbee6b9c725db8a5c898b597de8e667bef0.tar.gz
gnu: Add fasttree.
* gnu/packages/bioinformatics.scm (fasttree): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm59
1 files changed, 59 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 12c9175ed3..8dfaff3e00 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -780,6 +780,65 @@ analysis (from RNA-Seq), transcription factor binding quantification in
ChIP-Seq, and analysis of metagenomic data.")
(license license:artistic2.0)))
+(define-public fasttree
+ (package
+ (name "fasttree")
+ (version "2.1.8")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://www.microbesonline.org/fasttree/FastTree-"
+ version ".c"))
+ (sha256
+ (base32
+ "0dzqc9vr9iiiw21y159xfjl2z90vw0y7r4x6456pcaxiy5hd2wmi"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no "check" target
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'unpack)
+ (delete 'configure)
+ (replace 'build
+ (lambda* (#:key source #:allow-other-keys)
+ (and (zero? (system* "gcc"
+ "-O3"
+ "-finline-functions"
+ "-funroll-loops"
+ "-Wall"
+ "-o"
+ "FastTree"
+ source
+ "-lm"))
+ (zero? (system* "gcc"
+ "-DOPENMP"
+ "-fopenmp"
+ "-O3"
+ "-finline-functions"
+ "-funroll-loops"
+ "-Wall"
+ "-o"
+ "FastTreeMP"
+ source
+ "-lm")))))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((bin (string-append (assoc-ref outputs "out")
+ "/bin")))
+ (mkdir-p bin)
+ (copy-file "FastTree"
+ (string-append bin "/FastTree"))
+ (copy-file "FastTreeMP"
+ (string-append bin "/FastTreeMP"))
+ #t))))))
+ (home-page "http://www.microbesonline.org/fasttree")
+ (synopsis "Infers approximately-maximum-likelihood phylogenetic trees")
+ (description
+ "FastTree can handle alignments with up to a million of sequences in a
+reasonable amount of time and memory. For large alignments, FastTree is
+100-1,000 times faster than PhyML 3.0 or RAxML 7.")
+ (license license:gpl2+)))
+
(define-public fastx-toolkit
(package
(name "fastx-toolkit")