summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorXinglu Chen <public@yoctocell.xyz>2021-04-22 22:47:25 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-04-23 10:48:49 +0200
commit4091b6c4c2b76ac9308e8449e2b58c6a49455f0f (patch)
tree29c588a111970cc7808ea06b94659d0a1e79ddba /gnu
parent01b03c0a9af2b2f6e53ef69abeba2fcd031b79ad (diff)
downloadguix-patches-4091b6c4c2b76ac9308e8449e2b58c6a49455f0f.tar
guix-patches-4091b6c4c2b76ac9308e8449e2b58c6a49455f0f.tar.gz
gnu: Add emacs-vc-hgcmd.
* gnu/packages/emacs-xyz.scm (emacs-vc-hgcmd): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 35fc863a90..f0937d3759 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -318,6 +318,29 @@ using geiser.")
a generic Scheme interaction mode for the GNU Emacs editor.")
(license license:expat)))
+(define-public emacs-vc-hgcmd
+ (package
+ (name "emacs-vc-hgcmd")
+ (version "1.13")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/muffinmad/emacs-vc-hgcmd")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "14c2brvw6vnf1h3lbpap4jh5d7mjnzxrbny4jk77832v09mj2ria"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/muffinmad/emacs-vc-hgcmd")
+ (synopsis "Version control (VC) backend for the Mercurial command server")
+ (description
+ "This package provides an Emacs VC backend to work with Mercurial
+repositories through the
+@uref{https://www.mercurial-scm.org/wiki/CommandServer,Mercurial command
+server}. The main advantage compared to @code{vc-hg} is speed.")
+ (license license:gpl3+)))
+
(define-public emacs-hyperbole
(package
(name "emacs-hyperbole")