summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-07-28 20:22:54 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-07-28 20:31:06 +0200
commit45ee09dc96ae7d0c34daf56ed61f864675a5c7c5 (patch)
tree6b371f72a86781ebaaf706e4f5bd2cb264a9075c /gnu
parent532cfc5bd2c5c46f994a799776e643f702fefe38 (diff)
downloadguix-patches-45ee09dc96ae7d0c34daf56ed61f864675a5c7c5.tar
guix-patches-45ee09dc96ae7d0c34daf56ed61f864675a5c7c5.tar.gz
gnu: Add python-heapdict.
* gnu/packages/python-xyz.scm (python-heapdict): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f28d13dd98..0b1fdd0e69 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19514,6 +19514,26 @@ and works only with Python 2 and NumPy < 1.9.")
(define-public python2-phonenumbers
(package-with-python2 python-phonenumbers))
+(define-public python-heapdict
+ (package
+ (name "python-heapdict")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "HeapDict" version))
+ (sha256
+ (base32
+ "1dnd7v9adqd21bf4ih2wzn9a7b41m0nccb0vbxny9n037rxzb5c4"))))
+ (build-system python-build-system)
+ (home-page "http://stutzbachenterprises.com/")
+ (synopsis "Heap with decrease-key and increase-key operations")
+ (description
+ "heapdict implements the MutableMapping ABC, meaning it works pretty much
+like a regular Python @code{dict}. It’s designed to be used as a priority
+queue.")
+ (license license:bsd-3)))
+
(define-public python-send2trash
(package
(name "python-send2trash")