summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-07-28 20:23:03 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-07-28 20:31:06 +0200
commit41431282e2829f9af61f6cdccc15099d41ab0627 (patch)
treec9e77e942b4a6e68766eaf32f479546f943dff3b /gnu
parent45ee09dc96ae7d0c34daf56ed61f864675a5c7c5 (diff)
downloadguix-patches-41431282e2829f9af61f6cdccc15099d41ab0627.tar
guix-patches-41431282e2829f9af61f6cdccc15099d41ab0627.tar.gz
gnu: Add python-zict.
* gnu/packages/python-xyz.scm (python-zict): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0b1fdd0e69..e4dee0ab58 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -19534,6 +19534,30 @@ like a regular Python @code{dict}. It’s designed to be used as a priority
queue.")
(license license:bsd-3)))
+(define-public python-zict
+ (package
+ (name "python-zict")
+ (version "2.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "zict" version))
+ (sha256
+ (base32
+ "05pd1hyhqvpw87rnbvl3vdyf619snpyccbswaxisdj17frwnjacf"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-heapdict" ,python-heapdict)))
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "https://zict.readthedocs.io/en/latest/")
+ (synopsis "Composable mutable mapping tools")
+ (description "This package provides abstract @code{MutableMapping} classes
+that consume and build on other @code{MutableMappings}. Several of these can
+be composed with one another to form intuitive interfaces over complex storage
+systems policies.")
+ (license license:bsd-3)))
+
(define-public python-send2trash
(package
(name "python-send2trash")