summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-07-28 14:47:50 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-07-28 20:31:05 +0200
commit242221e38023d6528a5a698521fbc94821f49ada (patch)
treef3a379af21cf0ea922263f93a640126aed44fffc /gnu
parentf01d4b197aee89a4132d3d57fad55a6d1d0ddbc8 (diff)
downloadguix-patches-242221e38023d6528a5a698521fbc94821f49ada.tar
guix-patches-242221e38023d6528a5a698521fbc94821f49ada.tar.gz
gnu: python-dask: Update to 2021.7.1.
* gnu/packages/python-xyz.scm (python-dask): Update to 2021.7.1. [arguments]: Do not skip test_shuffle.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm13
1 files changed, 3 insertions, 10 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4846674111..f28d13dd98 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21623,13 +21623,13 @@ decisions with any given backend.")
(define-public python-dask
(package
(name "python-dask")
- (version "2.14.0")
+ (version "2021.7.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "dask" version))
(sha256
- (base32 "031j0j26s0675v0isyps2dphm03330n7dy8ifdy70jgvf78d119q"))))
+ (base32 "131c1bp193d7wp4gx09j6wark1c322c8sqjy22i0jaafl5rqfbz7"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -21640,14 +21640,7 @@ decisions with any given backend.")
(substitute* "dask/tests/test_threaded.py"
(("def test_interrupt\\(\\)" m)
(string-append "@pytest.mark.skip(reason=\"Disabled by Guix\")\n"
- m)))
- ;; This one fails with a type error:
- ;; TypeError: Already tz-aware, use tz_convert to convert.
- (substitute* "dask/dataframe/tests/test_shuffle.py"
- (("def test_set_index_timestamp\\(\\)" m)
- (string-append "@pytest.mark.skip(reason=\"Disabled by Guix\")\n"
- m)))
- #t))
+ m)))))
(replace 'check
(lambda _ (invoke "pytest" "-vv"))))))
(propagated-inputs