summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-05-21 22:26:13 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-05-31 15:39:00 +0200
commit7360dea62449d5c4f5ce897ee8f642090326ebc9 (patch)
tree1c0d895b37d777671f3a523c04e6e132b072f9ac /gnu
parent45b6db4fb4b6963be6fca4dc747d763673edce3c (diff)
downloadguix-patches-7360dea62449d5c4f5ce897ee8f642090326ebc9.tar
guix-patches-7360dea62449d5c4f5ce897ee8f642090326ebc9.tar.gz
gnu: r-rcas: Move to (gnu packages bioconductor).
* gnu/packages/bioinformatics.scm (r-rcas): Move from here... * gnu/packages/bioconductor.scm (r-rcas): ...to here.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm49
-rw-r--r--gnu/packages/bioinformatics.scm49
2 files changed, 49 insertions, 49 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 382e3b6d28..ca9e15d53e 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -3512,6 +3512,55 @@ proteomics packages.")
the graph algorithms contained in the Boost library.")
(license license:artistic2.0)))
+(define-public r-rcas
+ (package
+ (name "r-rcas")
+ (version "1.16.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "RCAS" version))
+ (sha256
+ (base32
+ "0vdxml618vqvf8xyh0zxs307p9zby0cj9dqyiiz625ilyq1hkw2m"))))
+ (properties `((upstream-name . "RCAS")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biocgenerics" ,r-biocgenerics)
+ ("r-biostrings" ,r-biostrings)
+ ("r-bsgenome" ,r-bsgenome)
+ ("r-bsgenome-hsapiens-ucsc-hg19" ,r-bsgenome-hsapiens-ucsc-hg19)
+ ("r-cowplot" ,r-cowplot)
+ ("r-data-table" ,r-data-table)
+ ("r-dt" ,r-dt)
+ ("r-genomation" ,r-genomation)
+ ("r-genomeinfodb" ,r-genomeinfodb)
+ ("r-genomicfeatures" ,r-genomicfeatures)
+ ("r-genomicranges" ,r-genomicranges)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-ggseqlogo" ,r-ggseqlogo)
+ ("r-gprofiler2" ,r-gprofiler2)
+ ("r-iranges" ,r-iranges)
+ ("r-pbapply" ,r-pbapply)
+ ("r-pheatmap" ,r-pheatmap)
+ ("r-plotly" ,r-plotly)
+ ("r-plotrix" ,r-plotrix)
+ ("r-proxy" ,r-proxy)
+ ("r-ranger" ,r-ranger)
+ ("r-rsqlite" ,r-rsqlite)
+ ("r-rtracklayer" ,r-rtracklayer)
+ ("r-rmarkdown" ,r-rmarkdown)
+ ("r-s4vectors" ,r-s4vectors)
+ ("pandoc" ,pandoc)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (synopsis "RNA-centric annotation system")
+ (description
+ "RCAS aims to be a standalone RNA-centric annotation system that provides
+intuitive reports and publication-ready graphics. This package provides the R
+library implementing most of the pipeline's features.")
+ (home-page "https://github.com/BIMSBbioinfo/RCAS")
+ (license license:artistic2.0)))
+
(define-public r-regioner
(package
(name "r-regioner")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 998541434f..e9eebd35b5 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8046,55 +8046,6 @@ characteristic tag shift values in these assays.")
secondary structure and comparative analysis in R.")
(license license:gpl3+)))
-(define-public r-rcas
- (package
- (name "r-rcas")
- (version "1.16.0")
- (source (origin
- (method url-fetch)
- (uri (bioconductor-uri "RCAS" version))
- (sha256
- (base32
- "0vdxml618vqvf8xyh0zxs307p9zby0cj9dqyiiz625ilyq1hkw2m"))))
- (properties `((upstream-name . "RCAS")))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-biocgenerics" ,r-biocgenerics)
- ("r-biostrings" ,r-biostrings)
- ("r-bsgenome" ,r-bsgenome)
- ("r-bsgenome-hsapiens-ucsc-hg19" ,r-bsgenome-hsapiens-ucsc-hg19)
- ("r-cowplot" ,r-cowplot)
- ("r-data-table" ,r-data-table)
- ("r-dt" ,r-dt)
- ("r-genomation" ,r-genomation)
- ("r-genomeinfodb" ,r-genomeinfodb)
- ("r-genomicfeatures" ,r-genomicfeatures)
- ("r-genomicranges" ,r-genomicranges)
- ("r-ggplot2" ,r-ggplot2)
- ("r-ggseqlogo" ,r-ggseqlogo)
- ("r-gprofiler2" ,r-gprofiler2)
- ("r-iranges" ,r-iranges)
- ("r-pbapply" ,r-pbapply)
- ("r-pheatmap" ,r-pheatmap)
- ("r-plotly" ,r-plotly)
- ("r-plotrix" ,r-plotrix)
- ("r-proxy" ,r-proxy)
- ("r-ranger" ,r-ranger)
- ("r-rsqlite" ,r-rsqlite)
- ("r-rtracklayer" ,r-rtracklayer)
- ("r-rmarkdown" ,r-rmarkdown)
- ("r-s4vectors" ,r-s4vectors)
- ("pandoc" ,pandoc)))
- (native-inputs
- `(("r-knitr" ,r-knitr)))
- (synopsis "RNA-centric annotation system")
- (description
- "RCAS aims to be a standalone RNA-centric annotation system that provides
-intuitive reports and publication-ready graphics. This package provides the R
-library implementing most of the pipeline's features.")
- (home-page "https://github.com/BIMSBbioinfo/RCAS")
- (license license:artistic2.0)))
-
(define-public rcas-web
(package
(name "rcas-web")