summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-02 10:36:41 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-02 10:36:41 +0100
commit15fd8dacb51e261f3b0970701acc651fb2e80a0e (patch)
tree2d3371938c9c1a7f9f03f169c2940390f9d25aeb /gnu
parentd3819cd23ad44abd95c1c16d7c7469fe235466a4 (diff)
downloadguix-patches-15fd8dacb51e261f3b0970701acc651fb2e80a0e.tar
guix-patches-15fd8dacb51e261f3b0970701acc651fb2e80a0e.tar.gz
gnu: emacs-pdf-tools: Update to 0.91.
* gnu/packages/emacs-xyz.scm (emacs-pdf-tools): Update to 0.91.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm133
1 files changed, 64 insertions, 69 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3e1f8b9e83..df03fb173f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3324,79 +3324,74 @@ during idle time, while Emacs is doing nothing else.")
(license license:gpl3+)))
(define-public emacs-pdf-tools
- ;; XXX: Development branch fixes an incompatibility with Emacs 27+. See
- ;; <https://github.com/politza/pdf-tools/issues/616>.
- (let ((commit "5f77dae43eb8f71e52e10ba8cf994883f74c3fb7")
- (revision "2"))
- (package
- (name "emacs-pdf-tools")
- (version (git-version "0.90" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/vedang/pdf-tools")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0hzqcnxi66d0c3dq7y3dn28f3yri4zcx46yylhy0xnm3f1yja0rm"))))
- (build-system gnu-build-system)
- (arguments
- `(#:tests? #f ; there are no tests
- #:modules ((guix build gnu-build-system)
- ((guix build emacs-build-system) #:prefix emacs:)
- (guix build utils)
- (guix build emacs-utils))
- #:imported-modules (,@%gnu-build-system-modules
- (guix build emacs-build-system)
- (guix build emacs-utils))
- #:phases
- (modify-phases %standard-phases
- ;; Build server side using 'gnu-build-system'.
- (add-after 'unpack 'enter-server-dir
- (lambda _ (chdir "server")))
- (add-after 'enter-server-dir 'autogen
- (lambda _
- (invoke "bash" "autogen.sh")))
-
- ;; Build emacs side using 'emacs-build-system'.
- (add-after 'compress-documentation 'enter-lisp-dir
- (lambda _ (chdir "../lisp")))
- (add-after 'enter-lisp-dir 'emacs-patch-variables
- (lambda* (#:key outputs #:allow-other-keys)
- (for-each make-file-writable (find-files "."))
+ (package
+ (name "emacs-pdf-tools")
+ (version "0.91")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vedang/pdf-tools")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "07ixspgn4s1jg66w7m2f3sh43giakz9srhp7rpw389z32g57i1rx"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; there are no tests
+ #:modules ((guix build gnu-build-system)
+ ((guix build emacs-build-system) #:prefix emacs:)
+ (guix build utils)
+ (guix build emacs-utils))
+ #:imported-modules (,@%gnu-build-system-modules
+ (guix build emacs-build-system)
+ (guix build emacs-utils))
+ #:phases
+ (modify-phases %standard-phases
+ ;; Build server side using 'gnu-build-system'.
+ (add-after 'unpack 'enter-server-dir
+ (lambda _ (chdir "server")))
+ (add-after 'enter-server-dir 'autogen
+ (lambda _
+ (invoke "bash" "autogen.sh")))
+ ;; Build emacs side using 'emacs-build-system'.
+ (add-after 'compress-documentation 'enter-lisp-dir
+ (lambda _ (chdir "../lisp")))
+ (add-after 'enter-lisp-dir 'emacs-patch-variables
+ (lambda* (#:key outputs #:allow-other-keys)
+ (for-each make-file-writable (find-files "."))
- ;; Set path to epdfinfo program.
- (emacs-substitute-variables "pdf-info.el"
- ("pdf-info-epdfinfo-program"
- (string-append (assoc-ref outputs "out")
- "/bin/epdfinfo")))
- ;; Set 'pdf-tools-handle-upgrades' to nil to avoid "auto
- ;; upgrading" that pdf-tools tries to perform.
- (emacs-substitute-variables "pdf-tools.el"
- ("pdf-tools-handle-upgrades" '()))))
- (add-after 'emacs-patch-variables 'emacs-expand-load-path
- (assoc-ref emacs:%standard-phases 'expand-load-path))
- (add-after 'emacs-expand-load-path 'emacs-install
- (assoc-ref emacs:%standard-phases 'install))
- (add-after 'emacs-install 'emacs-build
- (assoc-ref emacs:%standard-phases 'build))
- (add-after 'emacs-install 'emacs-make-autoloads
- (assoc-ref emacs:%standard-phases 'make-autoloads)))))
- (native-inputs
- (list autoconf automake emacs-minimal pkg-config))
- (inputs
- (list cairo glib libpng poppler zlib))
- (propagated-inputs
- (list emacs-tablist))
- (home-page "https://github.com/politza/pdf-tools")
- (synopsis "Emacs support library for PDF files")
- (description
- "PDF Tools is, among other things, a replacement of DocView for PDF
+ ;; Set path to epdfinfo program.
+ (emacs-substitute-variables "pdf-info.el"
+ ("pdf-info-epdfinfo-program"
+ (string-append (assoc-ref outputs "out")
+ "/bin/epdfinfo")))
+ ;; Set 'pdf-tools-handle-upgrades' to nil to avoid "auto
+ ;; upgrading" that pdf-tools tries to perform.
+ (emacs-substitute-variables "pdf-tools.el"
+ ("pdf-tools-handle-upgrades" '()))))
+ (add-after 'emacs-patch-variables 'emacs-expand-load-path
+ (assoc-ref emacs:%standard-phases 'expand-load-path))
+ (add-after 'emacs-expand-load-path 'emacs-install
+ (assoc-ref emacs:%standard-phases 'install))
+ (add-after 'emacs-install 'emacs-build
+ (assoc-ref emacs:%standard-phases 'build))
+ (add-after 'emacs-install 'emacs-make-autoloads
+ (assoc-ref emacs:%standard-phases 'make-autoloads)))))
+ (native-inputs
+ (list autoconf automake emacs-minimal pkg-config))
+ (inputs
+ (list cairo glib libpng poppler zlib))
+ (propagated-inputs
+ (list emacs-tablist))
+ (home-page "https://github.com/politza/pdf-tools")
+ (synopsis "Emacs support library for PDF files")
+ (description
+ "PDF Tools is, among other things, a replacement of DocView for PDF
files. The key difference is that pages are not pre-rendered by
e.g. ghostscript and stored in the file-system, but rather created on-demand
and stored in memory.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public emacs-saveplace-pdf-view
(package