summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-20 16:26:28 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-20 17:12:24 +0300
commitf2af6d371a072047854a28819af43325ba5d08d8 (patch)
tree57879bcffd4fdcb1c6a8686919552a3397990a7a /gnu
parent3372c562ebd8b4bd3a1a560b8b9f9f8f9642c5bc (diff)
downloadguix-patches-f2af6d371a072047854a28819af43325ba5d08d8.tar
guix-patches-f2af6d371a072047854a28819af43325ba5d08d8.tar.gz
gnu: Add julia-imagemagick-jll.
* gnu/packages/julia-xyz.scm (julia-imagemagick-jll): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/julia-xyz.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 8d3831ef40..b8fe48d2ed 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -26,6 +26,7 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages gcc)
#:use-module (gnu packages image)
+ #:use-module (gnu packages imagemagick)
#:use-module (gnu packages maths)
#:use-module (gnu packages tls)
#:use-module (gnu packages web))
@@ -793,6 +794,49 @@ library for parsing HTML.")
implementing both a client and a server.")
(license license:expat)))
+(define-public julia-imagemagick-jll
+ (package
+ (name "julia-imagemagick-jll")
+ (version "6.9.10-12+3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaBinaryWrappers/ImageMagick_jll.jl")
+ (commit (string-append "ImageMagick-v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1a0vnnjl52yqi7jgpr0dmx5ah5nlpylv5hc8aw2l89b9f36ff8jg"))))
+ (build-system julia-build-system)
+ (arguments
+ '(#:tests? #f ; no runtests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'override-binary-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (map
+ (lambda (wrapper)
+ (substitute* wrapper
+ ;; Make sure we match the current library.
+ (("libMagickWand-6.Q16.so.6") "libMagickWand-6.Q16.so.7")
+ (("artifact\"ImageMagick\"")
+ (string-append "\"" (assoc-ref inputs "imagemagick") "\""))))
+ ;; There's a Julia file for each platform, override them all
+ (find-files "src/wrappers/" "\\.jl$")))))))
+ (propagated-inputs
+ `(("julia-jllwrappers" ,julia-jllwrappers)
+ ("julia-jpegturbo-jll" ,julia-jpegturbo-jll)
+ ("julia-libpng-jll" ,julia-libpng-jll)
+ ("julia-libtiff-jll" ,julia-libtiff-jll)
+ ("julia-zlib-jll" ,julia-zlib-jll)))
+ (inputs
+ `(("imagemagick" ,imagemagick)))
+ (home-page "https://github.com/JuliaBinaryWrappers/ImageMagick_jll.jl")
+ (synopsis "Imagemagick library wrappers")
+ (description "This package provides a wrapper for Imagemagick.")
+ (license license:expat)))
+
(define-public julia-inifile
(package
(name "julia-inifile")