summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-03-31 15:41:41 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-04-14 14:53:31 +0200
commitdada39aaedba6dd44161478f9758ec97ead3fa27 (patch)
tree786ffaf2aafcd97e8172f94b125353de94535ed8 /gnu
parentb20abbcd7478eaa3d351af0ff2b0f63ce158871f (diff)
downloadguix-patches-dada39aaedba6dd44161478f9758ec97ead3fa27.tar
guix-patches-dada39aaedba6dd44161478f9758ec97ead3fa27.tar.gz
gnu: Add r-irlba.
* gnu/packages/statistics.scm (r-irlba): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/statistics.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 2dd744206d..ede353df10 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -2029,6 +2029,26 @@ The 'DataTables' library has been included in this R package.")
flexible than the orphaned \"base64\" package.")
(license license:gpl2+)))
+(define-public r-irlba
+ (package
+ (name "r-irlba")
+ (version "2.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "irlba" version))
+ (sha256
+ (base32
+ "1gms3rxrm24ri4vjvnpl4v47m7bx0zk63z8y85rbhsvx230xdy0m"))))
+ (build-system r-build-system)
+ (home-page "http://cran.r-project.org/web/packages/irlba")
+ (synopsis "Methods for eigendecomposition of large matrices")
+ (description
+ "This package provides fast and memory efficient methods for truncated
+singular and eigenvalue decompositions, as well as for principal component
+analysis of large sparse or dense matrices.")
+ (license (list license:gpl2+ license:gpl3+))))
+
(define-public r-r-methodss3
(package
(name "r-r-methodss3")