summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-11-07 12:34:26 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-11-07 12:34:26 +0200
commitd51b19adabb3449c1919eddd3510439e25d6cace (patch)
tree32850bd66cc0e7b2fae408acb96373fd02f58db0 /gnu
parent35407f948e74fd3ba55541137d47b1ff121baa9a (diff)
downloadguix-patches-d51b19adabb3449c1919eddd3510439e25d6cace.tar
guix-patches-d51b19adabb3449c1919eddd3510439e25d6cace.tar.gz
gnu: totem: Don't create icon cache.
* gnu/packages/gnome.scm (totem)[arguments]: Add phase to skip creating the gtk icon cache. [native-inputs]: Remove gtk+:bin.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d9364acd87..5843fe9708 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3947,7 +3947,6 @@ for application developers.")
("desktop-file-utils" ,desktop-file-utils)
("gobject-introspection" ,gobject-introspection)
("glib:bin" ,glib "bin") ;for 'glib-mkenums'
- ("gtk:bin" ,gtk+ "bin") ;for 'gtk-update-icon-cache'
("intltool" ,intltool)
("itstool" ,itstool)
("xmllint" ,libxml2)))
@@ -4003,6 +4002,12 @@ for application developers.")
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'skip-gtk-update-icon-cache
+ ;; Don't create 'icon-theme.cache'.
+ (lambda _
+ (substitute* "meson_post_install.py"
+ (("gtk-update-icon-cache") "true"))
+ #t))
(add-before
'install 'disable-cache-generation
(lambda _