summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-01-17 22:41:05 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-01-21 14:18:09 +0100
commitc3b2ab9d3bcc0bd8562365b6720c7b135e877f55 (patch)
tree8134fe7ee053acede180e3f269a16a58670ea4f0 /gnu
parentb0b7150b6ce275c3da64588726c936bfab8dc290 (diff)
downloadguix-patches-c3b2ab9d3bcc0bd8562365b6720c7b135e877f55.tar
guix-patches-c3b2ab9d3bcc0bd8562365b6720c7b135e877f55.tar.gz
gnu: Add libgff.
* gnu/packages/bioinformatics.scm (libgff): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm25
1 files changed, 24 insertions, 1 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index f0bfa9300b..f5e32ffa4d 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014, 2015, 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2014, 2015, 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2016, 2017 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2015, 2016 Pjotr Prins <pjotr.guix@thebird.nl>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
@@ -11109,3 +11109,26 @@ for alignment. Pseudoalignment of reads preserves the key information needed
for quantification, and kallisto is therefore not only fast, but also as
accurate as existing quantification tools.")
(license license:bsd-2)))
+
+(define-public libgff
+ (package
+ (name "libgff")
+ (version "1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/Kingsford-Group/"
+ "libgff/archive/v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0vc4nxyhlm6g9vvmx5l4lfs5pnvixsv1hiiy4kddf2y3p6jna8ls"))))
+ (build-system cmake-build-system)
+ (arguments `(#:tests? #f)) ; no tests included
+ (home-page "https://github.com/Kingsford-Group/libgff")
+ (synopsis "Parser library for reading/writing GFF files")
+ (description "This is a simple \"libraryfication\" of the GFF/GTF parsing
+code that is used in the Cufflinks codebase. The goal of this library is to
+provide this functionality without the necessity of drawing in a heavy-weight
+dependency like SeqAn.")
+ (license (license:x11-style "http://www.boost.org/LICENSE_1_0.txt"))))