summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-20 16:43:46 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-20 17:12:25 +0300
commitc1f7692fcac793603e0e15c99e8530c015eda302 (patch)
treed110e2bf0b1ddc70420765efa66d8a41dc995109 /gnu
parent9f3dae8f61bdc60b699d3361c0dc21f6999203af (diff)
downloadguix-patches-c1f7692fcac793603e0e15c99e8530c015eda302.tar
guix-patches-c1f7692fcac793603e0e15c99e8530c015eda302.tar.gz
gnu: Add julia-unpack.
* gnu/packages/julia-xyz.scm (julia-unpack): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/julia-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index ebe7e860d7..72a60ad6d7 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1551,6 +1551,26 @@ linear algebra operations.")
warnings (stderr) or both streams at the same time.")
(license license:expat)))
+(define-public julia-unpack
+ (package
+ (name "julia-unpack")
+ (version "1.0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mauro3/UnPack.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "066v1px72zidnvhl0rczhh07rcfwvli0jx5nprrgyi1dvj3mps2a"))))
+ (build-system julia-build-system)
+ (home-page "https://github.com/mauro3/UnPack.jl")
+ (synopsis "Pack and Unpack macros for Julia")
+ (description "The @code{@@unpack} and @code{@@pack!} macros work to unpack
+types, modules, and dictionaries.")
+ (license license:expat)))
+
(define-public julia-uris
(package
(name "julia-uris")