summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-10-25 17:37:24 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 22:36:17 +0100
commitb9c8ccce049cd4e5cd6e3800eb7f3033e0b09050 (patch)
tree2bac36554a65598623d5450b4898998f340a87d8 /gnu
parent011271c769552b284cf7cf2081eb28e999f42e41 (diff)
downloadguix-patches-b9c8ccce049cd4e5cd6e3800eb7f3033e0b09050.tar
guix-patches-b9c8ccce049cd4e5cd6e3800eb7f3033e0b09050.tar.gz
gnu: python-flake8-2.2.4: Remove python byte-code files from source.
* gnu/packages/python.scm (python-flake8-2.2.4)[source]: Add snippet.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 823624fc1b..9f07ead921 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5647,7 +5647,15 @@ complexity of Python source code.")
(uri (pypi-uri "flake8" version))
(sha256
(base32
- "1r9wsry4va45h1rck5hxd3vzsg2q3y6lnl6pym1bxvz8ry19jwx8"))))))
+ "1r9wsry4va45h1rck5hxd3vzsg2q3y6lnl6pym1bxvz8ry19jwx8"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Remove pre-compiled .pyc files from source.
+ (for-each delete-file-recursively
+ (find-files "." "__pycache__" #:directories? #t))
+ (for-each delete-file (find-files "." "\\.pyc$"))
+ #t))))))
(define-public python2-flake8-2.2.4
(package-with-python2 python-flake8-2.2.4))