summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-03-31 15:39:16 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-04-14 14:53:31 +0200
commitb1acb4457392a8ff3f3f8952d9c2464b3d04a9a0 (patch)
treeec5f8f77d4a4a04ee825ff6131dc79c74203162e /gnu
parent0837dd0737b18301173ca07acb5df53f3230f1d0 (diff)
downloadguix-patches-b1acb4457392a8ff3f3f8952d9c2464b3d04a9a0.tar
guix-patches-b1acb4457392a8ff3f3f8952d9c2464b3d04a9a0.tar.gz
gnu: Add r-formula.
* gnu/packages/statistics.scm (r-formula): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/statistics.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index e266a0ab5e..fb05d8347e 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -1007,6 +1007,28 @@ some versions of Epi Info, Minitab, S, SAS, SPSS, Stata, Systat and Weka, and
for reading and writing some dBase files.")
(license license:gpl2+)))
+(define-public r-formula
+ (package
+ (name "r-formula")
+ (version "1.2-1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "Formula" version))
+ (sha256
+ (base32
+ "02in5325zzrqbhlygx6s0dinj6ymw845q70y56frqacv25ayzcax"))))
+ (properties `((upstream-name . "Formula")))
+ (build-system r-build-system)
+ (home-page "http://cran.r-project.org/web/packages/Formula")
+ (synopsis "Extended model formulas")
+ (description
+ "This package provides a new class @code{Formula}, which extends the base
+class @code{formula}. It supports extended formulas with multiple parts of
+regressors on the right-hand side and/or multiple responses on the left-hand
+side.")
+ (license (list license:gpl2+ license:gpl3+))))
+
(define-public r-chron
(package
(name "r-chron")