summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-10-06 22:13:04 +0200
committerLudovic Courtès <ludo@gnu.org>2013-10-06 22:36:43 +0200
commitae0c12023d6042801c7cc9d803424452adada50b (patch)
tree727fe07fc1f656a6c1079e3de70b04def95dcbfd /gnu
parent74067e1aeb5f5ce3de7ec1d7e9f8d68f695f69cc (diff)
downloadguix-patches-ae0c12023d6042801c7cc9d803424452adada50b.tar
guix-patches-ae0c12023d6042801c7cc9d803424452adada50b.tar.gz
gnu: xmlto: Keep references to libxml2, libxslt, and util-linux programs.
* gnu/packages/xml.scm (xmlto): Add 'arguments' field. [inputs]: Add libxml2 and libxslt.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xml.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index fb50c25c09..b16b2a3f1f 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -177,8 +177,16 @@ parser modules).")
(base32
"0dp5nxq491gymq806za0dk4hngfmq65ysrqbn0ypajqbbl6vf71n"))))
(build-system gnu-build-system)
+ (arguments
+ ;; Make sure the reference to util-linux's 'getopt' is kept in 'xmlto'.
+ '(#:configure-flags (list (string-append "GETOPT="
+ (assoc-ref %build-inputs
+ "util-linux")
+ "/bin/getopt"))))
(inputs
- `(("util-linux" ,util-linux)))
+ `(("util-linux" ,util-linux) ; for 'getopt'
+ ("libxml2" ,libxml2) ; for 'xmllint'
+ ("libxslt" ,libxslt))) ; for 'xsltproc'
(home-page "http://cyberelk.net/tim/software/xmlto/")
(synopsis "Front-end to an XSL toolchain")
(description