summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorng0 <ng0@libertad.pw>2016-11-22 23:57:04 +0000
committerMarius Bakke <mbakke@fastmail.com>2016-11-23 16:46:47 +0100
commit8a28e717ba702bea69ec8ecfcdb512c8ded39be2 (patch)
tree4fe066cf60984d9ee32ac75011b5972bde3eeb9b /gnu
parentbc05caee77b30c053e6e94a3814e22eed902188f (diff)
downloadguix-patches-8a28e717ba702bea69ec8ecfcdb512c8ded39be2.tar
guix-patches-8a28e717ba702bea69ec8ecfcdb512c8ded39be2.tar.gz
gnu: Add perl-digest-md5.
* gnu/packages/perl.scm (perl-digest-md5): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm31
1 files changed, 30 insertions, 1 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index ab6120142d..d332e2aa1e 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -7,7 +7,7 @@
;;; Copyright © 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016 Jochem Raat <jchmrt@riseup.net>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
-;;; Coypright © 2016 ng0 <ng0@we.make.ritual.n0.is>
+;;; Coypright © 2016 ng0 <ng0@libertad.pw>
;;; Copyright © 2016 Alex Sassmannshausen <alex@pompo.co>
;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
@@ -2055,6 +2055,35 @@ each stack frame.")
interface for the RFC 2104 HMAC mechanism.")
(license (package-license perl))))
+(define-public perl-digest-md5
+ (package
+ (name "perl-digest-md5")
+ (version "2.55")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/G/GA/GAAS/Digest-MD5-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0g0fklbrm2krswc1xhp4iwn1dhqq71fqh2p5wm8xj9a4s6i9ic83"))))
+ (build-system perl-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'build 'set-permissions
+ (lambda _
+ ;; Make MD5.so read-write so it can be stripped.
+ (chmod "blib/arch/auto/Digest/MD5/MD5.so" #o755)))))))
+ (home-page "http://search.cpan.org/dist/Digest-MD5")
+ (synopsis "Perl interface to the MD-5 algorithm")
+ (description
+ "The @code{Digest::MD5} module allows you to use the MD5 Message Digest
+algorithm from within Perl programs. The algorithm takes as
+input a message of arbitrary length and produces as output a
+128-bit \"fingerprint\" or \"message digest\" of the input.")
+ (license (package-license perl))))
+
(define-public perl-digest-sha1
(package
(name "perl-digest-sha1")