summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2017-02-09 18:33:36 -0500
committerMark H Weaver <mhw@netris.org>2017-02-09 18:33:36 -0500
commit76e62ef723fa228e455ec6326aaec87925bd5cf2 (patch)
tree47c0037750ce7b441b77301482be1191af547c5b /gnu
parent69ff1794b305df8293580f7ed967d09a8bde3aeb (diff)
downloadguix-patches-76e62ef723fa228e455ec6326aaec87925bd5cf2.tar
guix-patches-76e62ef723fa228e455ec6326aaec87925bd5cf2.tar.gz
gnu: linux-libre: Use %linux-libre-{version,hash} in package definition.
* gnu/packages/linux.scm (%linux-libre-version, %linux-libre-hash): Move above definition of 'linux-libre'. Remove comment about avoiding minor version bumps. (linux-libre): Use %linux-libre-version and %linux-libre-hash to avoid duplicate copies of that information.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 36206b7654..6fbbd1dfe5 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -338,9 +338,12 @@ It has been modified to remove all non-free binary blobs.")
(define %intel-compatible-systems '("x86_64-linux" "i686-linux"))
+(define %linux-libre-version "4.9.8")
+(define %linux-libre-hash "09cx8l0bbccz14ajbawqaq4ah9jpld44pkb61483xwdp9v2sihm3")
+
(define-public linux-libre
- (make-linux-libre "4.9.8"
- "09cx8l0bbccz14ajbawqaq4ah9jpld44pkb61483xwdp9v2sihm3"
+ (make-linux-libre %linux-libre-version
+ %linux-libre-hash
%intel-compatible-systems
#:configuration-file kernel-config))
@@ -356,10 +359,6 @@ It has been modified to remove all non-free binary blobs.")
%intel-compatible-systems
#:configuration-file kernel-config))
-;; Avoid rebuilding kernel variants when there is a minor version bump.
-(define %linux-libre-version "4.9.8")
-(define %linux-libre-hash "09cx8l0bbccz14ajbawqaq4ah9jpld44pkb61483xwdp9v2sihm3")
-
(define-public linux-libre-arm-generic
(make-linux-libre %linux-libre-version
%linux-libre-hash