summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2016-04-08 21:57:11 +0300
committerAlex Kost <alezost@gmail.com>2016-04-17 10:33:08 +0300
commit5953d2b7c0f1d502cdc3205fc296299a985ce781 (patch)
treede094794fb34f7e93ca3e8792fd2ecf9542164e6 /gnu
parenta1ccefaa122df7c0045eda1fe6b65d83b65ed238 (diff)
downloadguix-patches-5953d2b7c0f1d502cdc3205fc296299a985ce781.tar
guix-patches-5953d2b7c0f1d502cdc3205fc296299a985ce781.tar.gz
gnu: kbd: Use 'modify-phases'.
* gnu/packages/linux.scm (kbd)[arguments]: Use 'modify-phases'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm41
1 files changed, 20 insertions, 21 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index e4426e9e2a..1b84242968 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1485,27 +1485,26 @@ system.")
"tty"))))))
(build-system gnu-build-system)
(arguments
- '(#:phases (alist-cons-before
- 'build 'pre-build
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((gzip (assoc-ref %build-inputs "gzip"))
- (bzip2 (assoc-ref %build-inputs "bzip2")))
- (substitute* "src/libkeymap/findfile.c"
- (("gzip")
- (string-append gzip "/bin/gzip"))
- (("bzip2")
- (string-append bzip2 "/bin/bzip2")))))
- (alist-cons-after
- 'install 'post-install
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Make sure these programs find their comrades.
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin")))
- (for-each (lambda (prog)
- (wrap-program (string-append bin "/" prog)
- `("PATH" ":" prefix (,bin))))
- '("unicode_start" "unicode_stop"))))
- %standard-phases))))
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'pre-build
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((gzip (assoc-ref %build-inputs "gzip"))
+ (bzip2 (assoc-ref %build-inputs "bzip2")))
+ (substitute* "src/libkeymap/findfile.c"
+ (("gzip")
+ (string-append gzip "/bin/gzip"))
+ (("bzip2")
+ (string-append bzip2 "/bin/bzip2"))))))
+ (add-after 'install 'post-install
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Make sure these programs find their comrades.
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (for-each (lambda (prog)
+ (wrap-program (string-append bin "/" prog)
+ `("PATH" ":" prefix (,bin))))
+ '("unicode_start" "unicode_stop"))))))))
(inputs `(("check" ,check)
("gzip" ,gzip)
("bzip2" ,bzip2)