summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-07-22 00:01:03 +0000
committerEfraim Flashner <efraim@flashner.co.il>2016-07-24 09:36:42 +0300
commit578aeea6cd949fb5daf683378c5c6c154bafd184 (patch)
tree623d167398bd986704708308c9bfbb0a6e9626b6 /gnu
parent73020459b31330717b24e55d5b0629976b20ea8b (diff)
downloadguix-patches-578aeea6cd949fb5daf683378c5c6c154bafd184.tar
guix-patches-578aeea6cd949fb5daf683378c5c6c154bafd184.tar.gz
gnu: perl-io-socket-ssl: Add IDN support.
* gnu/packages/web.scm (perl-io-socket-ssl)[propagated-inputs]: Add perl-uri for IDN support. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index c2cae27270..33c1e88a5d 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -2401,7 +2401,10 @@ and IPv6 sockets, intended as a replacement for IO::Socket::INET.")
(patches (search-patches
"perl-io-socket-ssl-openssl-1.0.2f-fix.patch"))))
(build-system perl-build-system)
- (propagated-inputs `(("perl-net-ssleay" ,perl-net-ssleay)))
+ (propagated-inputs
+ `(("perl-net-ssleay" ,perl-net-ssleay)
+ ;; for IDN support
+ ("perl-uri" ,perl-uri)))
(synopsis "Nearly transparent SSL encapsulation for IO::Socket::INET")
(description
"IO::Socket::SSL makes using SSL/TLS much easier by wrapping the