summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-20 16:23:34 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-20 17:12:24 +0300
commit3372c562ebd8b4bd3a1a560b8b9f9f8f9642c5bc (patch)
treeca2ea8cba9cce78feb99c00ddf344a9c9ed0c7eb /gnu
parentf16cf693e9ddcf775667c1616eb54b17a600c416 (diff)
downloadguix-patches-3372c562ebd8b4bd3a1a560b8b9f9f8f9642c5bc.tar
guix-patches-3372c562ebd8b4bd3a1a560b8b9f9f8f9642c5bc.tar.gz
gnu: Add julia-libtiff-jll.
* gnu/packages/julia-xyz.scm (julia-libtiff-jll): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/julia-xyz.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 624576b038..8d3831ef40 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1003,6 +1003,46 @@ and printing JSON documents.")
(description "This package provides a wrapper for the libpng library.")
(license license:expat)))
+(define-public julia-libtiff-jll
+ (package
+ (name "julia-libtiff-jll")
+ (version "4.1.0+1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaBinaryWrappers/Libtiff_jll.jl")
+ (commit (string-append "Libtiff-v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "07zzhmwmh2g4645ghv76z40hza2ghlb7sw15b1pii7f9kfcsgf45"))))
+ (build-system julia-build-system)
+ (arguments
+ '(#:tests? #f ; no runtests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'override-binary-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (map
+ (lambda (wrapper)
+ (substitute* wrapper
+ (("artifact\"Libtiff\"")
+ (string-append "\"" (assoc-ref inputs "libtiff") "\""))))
+ ;; There's a Julia file for each platform, override them all
+ (find-files "src/wrappers/" "\\.jl$")))))))
+ (inputs
+ `(("libtiff" ,libtiff)))
+ (propagated-inputs
+ `(("julia-jllwrappers" ,julia-jllwrappers)
+ ("julia-jpegturbo-jll" ,julia-jpegturbo-jll)
+ ("julia-zlib-jll" ,julia-zlib-jll)
+ ("julia-zstd-jll" ,julia-zstd-jll)))
+ (home-page "https://github.com/JuliaBinaryWrappers/Libtiff_jll.jl")
+ (synopsis "Libtiff library wrappers")
+ (description "This package provides a wrapper for libtiff")
+ (license license:expat)))
+
(define-public julia-macrotools
(package
(name "julia-macrotools")