summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMuriithi Frederick Muriuki <fredmanglis@gmail.com>2017-02-09 20:48:35 +0300
committerMarius Bakke <mbakke@fastmail.com>2017-02-09 23:41:24 +0100
commit2299b13738ae819a9c34ebe396bd2adfe426b0ba (patch)
tree78020ffc78d02396ab8f0100f76e2753f8b9d48c /gnu
parent2f4623dbd85bab738056e5898ea9a2aadfc49733 (diff)
downloadguix-patches-2299b13738ae819a9c34ebe396bd2adfe426b0ba.tar
guix-patches-2299b13738ae819a9c34ebe396bd2adfe426b0ba.tar.gz
gnu: Add python-pycosat.
* gnu/packages/python.scm (python-pycosat, python2-pycosat): New variables. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 7ee9376f21..a4f5edc7ea 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -12608,3 +12608,28 @@ it with different test data, and make it appear as multiple test cases.")
(define-public python2-ddt
(package-with-python2 python-ddt))
+
+(define-public python-pycosat
+ (package
+ (name "python-pycosat")
+ (version "0.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pycosat" version))
+ (sha256
+ (base32
+ "1kl3wh1f47rc712n4bmwplbx3fqz3x9i1b587jrbpmvdva4c8f6l"))))
+ ;; TODO: Unundle picosat. http://fmv.jku.at/picosat/
+ (build-system python-build-system)
+ (home-page "https://github.com/ContinuumIO/pycosat")
+ (synopsis "Bindings to picosat (a SAT solver)")
+ (description
+ "This package provides efficient Python bindings to @code{picosat} on
+the C level. When importing pycosat, the @code{picosat} solver becomes part
+of the Python process itself. @code{picosat} is a @dfn{Boolean Satisfiability
+Problem} (SAT) solver.")
+ (license license:expat)))
+
+(define-public python2-pycosat
+ (package-with-python2 python-pycosat))