summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-12-18 19:25:36 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-01-21 19:38:50 +0100
commit220ed20b225414a466d4e35d0724ecd0ad5a0127 (patch)
treee8edb9a4496768dcd78cc9df75ae43764991612e /gnu
parent0b88f536db025fb8d8722089f61fc1d01e4c66ca (diff)
downloadguix-patches-220ed20b225414a466d4e35d0724ecd0ad5a0127.tar
guix-patches-220ed20b225414a466d4e35d0724ecd0ad5a0127.tar.gz
gnu: Add python-txamqp.
* gnu/packages/python.scm (python-txamqp, python2-txamqp): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 9b9b22be28..3c40f00edd 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7598,6 +7598,35 @@ alternative when librabbitmq is not available.")
#:tests? #f
,@(package-arguments amqp))))))
+(define-public python-txamqp
+ (package
+ (name "python-txamqp")
+ (version "0.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "txAMQP" version))
+ (sha256
+ (base32
+ "1r43a66dd547mz40ikymm8y3d480cidy560fj81qc0jk4lncgmmr"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-six" ,python-six)
+ ("python-twisted" ,python-twisted)))
+ (home-page "https://github.com/txamqp/txamqp")
+ (synopsis "Communicate with AMQP peers and brokers using Twisted")
+ (description
+ "This package provides a Python library for communicating with AMQP peers
+and brokers using the asynchronous networking framework Twisted. It contains
+all the necessary code to connect, send and receive messages to/from an
+AMQP-compliant peer or broker (Qpid, OpenAMQ, RabbitMQ) using Twisted. It
+also includes support for using Thrift RPC over AMQP in Twisted
+applications.")
+ (license license:asl2.0)))
+
+(define-public python2-txamqp
+ (package-with-python2 python-txamqp))
+
(define-public python-kombu
(package
(name "python-kombu")