summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-06-29 03:12:28 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-06-29 05:18:51 +0200
commit16c0380871ce772fa4897253e885f7d9fb781d20 (patch)
tree0b492c6813bfa0afe1ce8bc09c7361b73a43ebe2 /gnu
parent1ef68130a3f99b5695a5a6f7b369560a1d61df66 (diff)
downloadguix-patches-16c0380871ce772fa4897253e885f7d9fb781d20.tar
guix-patches-16c0380871ce772fa4897253e885f7d9fb781d20.tar.gz
gnu: powerstat: Update to 0.02.26.
* gnu/packages/linux.scm (powerstat): Update to 0.02.26. [arguments]: Remove obsolete 'respect-$prefix phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm10
1 files changed, 2 insertions, 8 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 8afbf9de0c..8426486fcf 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1532,14 +1532,14 @@ at login. Local and dynamic reconfiguration are its key features.")
(define-public powerstat
(package
(name "powerstat")
- (version "0.02.25")
+ (version "0.02.26")
(source
(origin
(method url-fetch)
(uri (string-append "https://kernel.ubuntu.com/~cking/tarballs/"
"powerstat/powerstat-" version ".tar.gz"))
(sha256
- (base32 "0dmixbxm4qd08ds26i0wvxwyy8nrjzfjj2q9ylx35564g4wh58qb"))))
+ (base32 "18m85k83hryj05vix63fay1hh0sb9h87hy5r7g1dqg2y9i8lzgxk"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags
@@ -1548,12 +1548,6 @@ at login. Local and dynamic reconfiguration are its key features.")
#:tests? #f ; no test suite
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'respect-$prefix
- ;; https://bugs.launchpad.net/ubuntu/+source/powerstat/+bug/1877744
- (lambda _
- (substitute* "Makefile"
- (("DIR=/usr/") "DIR=$(prefix)/"))
- #t))
(delete 'configure)))) ; no configure script
(home-page "https://kernel.ubuntu.com/~cking/powerstat/")
(synopsis "Measure system power consumption")