summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-06-29 05:17:54 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-06-29 05:18:50 +0200
commit13d938bead8e7b3972bfbd78ccc45e10d682875d (patch)
tree8247a14aef9b84476c7cc6ed681d6cbf07be2e56 /gnu
parent32037d8f3433155d8deeb489394fd90e01b55646 (diff)
downloadguix-patches-13d938bead8e7b3972bfbd78ccc45e10d682875d.tar
guix-patches-13d938bead8e7b3972bfbd78ccc45e10d682875d.tar.gz
gnu: cgal: Remove duplicate licence directory.
* gnu/packages/graphics.scm (cgal)[arguments]: Set CGAL_INSTALL_DOC_DIR to match Guix's own default in #:configure-flags.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/graphics.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 9925a72763..cc3a7c9641 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -772,7 +772,12 @@ more.")
"0yjzq12ivizp23y7zqm30x20psv9gzwbcdrhyd3f7h0ds94m1c40"))))
(build-system cmake-build-system)
(arguments
- '(#:tests? #f)) ; no test target
+ `(#:configure-flags
+ ;; Prevent two mostly-duplicate directories. Use Guix's versioned
+ ;; default for licences instead of CGAL's unversioned one.
+ (list (string-append "-DCGAL_INSTALL_DOC_DIR=share/doc/"
+ ,name "-" ,version))
+ #:tests? #f)) ; no test target
(inputs
`(("mpfr" ,mpfr)
("gmp" ,gmp)