summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-10-25 18:15:29 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 22:36:09 +0100
commit011271c769552b284cf7cf2081eb28e999f42e41 (patch)
tree20407e62cf886294315a101afdb9a942825fc365 /gnu
parentbac6816879248864d28f71c02414e89f071a81fe (diff)
downloadguix-patches-011271c769552b284cf7cf2081eb28e999f42e41.tar
guix-patches-011271c769552b284cf7cf2081eb28e999f42e41.tar.gz
gnu: python-flake8: Remove python byte-code files from source.
* gnu/packages/python.scm (python-flake8)[source]: Add snippet.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index a2aebbd829..823624fc1b 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5602,7 +5602,15 @@ complexity of Python source code.")
(uri (pypi-uri "flake8" version))
(sha256
(base32
- "0bs9cz4fr99r2rwig1b8jwaadl1nan7kgpdzqwj0bwbckwbmh7nc"))))
+ "0bs9cz4fr99r2rwig1b8jwaadl1nan7kgpdzqwj0bwbckwbmh7nc"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Remove pre-compiled .pyc files from source.
+ (for-each delete-file-recursively
+ (find-files "." "__pycache__" #:directories? #t))
+ (for-each delete-file (find-files "." "\\.pyc$"))
+ #t))))
(build-system python-build-system)
(propagated-inputs
`(("python-pep8" ,python-pep8)