summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-09-24 16:17:26 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-02 10:54:22 +0000
commitff0f9ab7d683131a70fa9c0bbb7baebc31d8ba6a (patch)
treeea4f9b2f6e33a889f9b35836daf127ea7857a643 /gnu
parent6f4b1e4d79e0684312d776de3e99931c0162a650 (diff)
downloadguix-patches-ff0f9ab7d683131a70fa9c0bbb7baebc31d8ba6a.tar
guix-patches-ff0f9ab7d683131a70fa9c0bbb7baebc31d8ba6a.tar.gz
gnu: tepl: Update to 6.00.0.
* gnu/packages/gnome.scm (tepl): Update to 6.00.0. [build-system]: Switch to meson. [arguments]: Set glib-or-gtk? to true. [native-inputs]: Add glib@bin.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 73174924c8..a7e4561204 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1022,7 +1022,7 @@ between different kinds of computer systems.")
(define-public tepl
(package
(name "tepl")
- (version "4.4.0")
+ (version "6.00.0")
(source
(origin
(method url-fetch)
@@ -1032,12 +1032,14 @@ between different kinds of computer systems.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0mm2z849hnni7597an05mrv0dckrxjngpf2xfa0g5s17i8x6gxp6"))))
- (build-system glib-or-gtk-build-system)
+ "0qvs7s86gqyyrzi0r5fbrj8zczlgv8xhdjswgbgc1afwjnl9fqx8"))))
+ (build-system meson-build-system)
(arguments
- `(#:tests? #f)) ; FIX-ME: Requires gvfs
+ `(#:glib-or-gtk? #t
+ #:tests? #f)) ; FIX-ME: Requires gvfs
(native-inputs
- `(("gobject-introspection" ,gobject-introspection)
+ `(("glib" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
("pkg-config" ,pkg-config)))
(inputs
`(("amtk" ,amtk)