summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-09-24 15:44:51 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-02 10:54:21 +0000
commitcb79e5a175b248ad25d16b280cf771c50c2b35a4 (patch)
tree732a74c52c875d07a9e8d181ab863eadaee25052 /gnu
parent0a0c8f426cd238894dd3c1db688c410a71fdcc6c (diff)
downloadguix-patches-cb79e5a175b248ad25d16b280cf771c50c2b35a4.tar
guix-patches-cb79e5a175b248ad25d16b280cf771c50c2b35a4.tar.gz
gnu: gnome-calculator: Update to 40.1.
* gnu/packages/gnome.scm (gnome-calculator): Update to 40.1. [source]: Fix the URL. [arguments]: Add a 'pre-check phase. [inputs]: Add libhandy.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm16
1 files changed, 12 insertions, 4 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 4c1a3324ed..6440778276 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -9981,18 +9981,25 @@ handling the startup notification side.")
(define-public gnome-calculator
(package
(name "gnome-calculator")
- (version "3.36.0")
+ (version "40.1")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
- (version-major+minor version) "/"
+ (version-major version) "/"
name "-" version ".tar.xz"))
(sha256
(base32
- "1cqd4b25qp1i0p04m669jssg1l5sdapc1mniv9jssvw5r7wk1s52"))))
+ "1xkazxbkpn1z5pfphhps7fc5q4yc8lp7f6b222n8bx5iyxhwbrkz"))))
(build-system meson-build-system)
- (arguments '(#:glib-or-gtk? #t))
+ (arguments
+ '(#:glib-or-gtk? #t
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'pre-check
+ (lambda _
+ ;; Tests require a writable HOME.
+ (setenv "HOME" (getcwd)))))))
(native-inputs
`(("gettext" ,gettext-minimal)
("glib:bin" ,glib "bin") ; for glib-compile-schemas, gio-2.0.
@@ -10004,6 +10011,7 @@ handling the startup notification side.")
`(("glib" ,glib)
("gtksourceview" ,gtksourceview)
("libgee" ,libgee)
+ ("libhandy" ,libhandy)
("libsoup" ,libsoup)
("libxml2" ,libxml2)
("mpc" ,mpc)