summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorKei Kebreau <kei@openmailbox.org>2016-08-29 12:42:51 -0400
committerKei Kebreau <kei@openmailbox.org>2016-08-30 17:35:53 -0400
commitbb8b543a488a46db37211d9b9f2d2e7ea42ed40e (patch)
tree1faa35e511ca38adde5041f98579e7aab317eb8d /gnu
parent72783891fea75b49d96c74efb4f16014b249b6dc (diff)
downloadguix-patches-bb8b543a488a46db37211d9b9f2d2e7ea42ed40e.tar
guix-patches-bb8b543a488a46db37211d9b9f2d2e7ea42ed40e.tar.gz
gnu: Add telepathy-idle.
* gnu/packages/freedesktop.scm (telepathy-idle): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/freedesktop.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 67f1e1a2c0..ac98769bd1 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -618,6 +619,34 @@ received by the Telepathy framework. It features pluggable backends to log
different sorts of messages in different formats.")
(license license:lgpl2.1+)))
+(define-public telepathy-idle
+ (package
+ (name "telepathy-idle")
+ (version "0.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://telepathy.freedesktop.org/releases/"
+ name "/" name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1argdzbif1vdmwp5vqbgkadq9ancjmgdm2ncp0qfckni715ss4rh"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("xsltproc" ,libxslt)
+ ("python" ,python-2)
+ ("python-dbus" ,python2-dbus)))
+ (propagated-inputs
+ `(("telepathy-glib" ,telepathy-glib)))
+ (home-page "http://telepathy.freedesktop.org/")
+ (synopsis "Telepathy IRC connection manager")
+ (description
+ "Idle is an IRC connection manager for the Telepathy framework. This
+package enables usage of IRC channels and private messages in Telepathy instant
+messaging clients such as Empathy, GNOME Shell or KDE Telepathy.")
+ (license (list license:lgpl2.1 license:lgpl2.1+))))
+
(define-public colord-gtk
(package
(name "colord-gtk")