summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-08-29 00:16:52 +0000
committerAlex Kost <alezost@gmail.com>2016-08-31 10:10:30 +0300
commit840224aadcc5b4f1b0895ae23ab9810d0b12e9ec (patch)
tree23eb937302f867e89767853eb8b76705e6375f2f /gnu
parent9657aba4ed92d4965e89122dc086f96f1f06d3fc (diff)
downloadguix-patches-840224aadcc5b4f1b0895ae23ab9810d0b12e9ec.tar
guix-patches-840224aadcc5b4f1b0895ae23ab9810d0b12e9ec.tar.gz
gnu: Add emacs-auto-complete.
* gnu/packages/emacs.scm (emacs-auto-complete): New variable. Signed-off-by: Alex Kost <alezost@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 3088c0a566..ad51634f0c 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -3047,3 +3047,29 @@ Flx has support for ido (interactively do things) through flx-ido.")
"Cyberpunk color theme for the emacs 24+ built-in color theme support
known loosely as deftheme. Many mode-specific customizations are included.")
(license license:gpl3+)))
+
+(define-public emacs-auto-complete
+ (package
+ (name "emacs-auto-complete")
+ (version "1.5.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/auto-complete/"
+ "auto-complete/archive/v" version ".tar.gz"))
+ (sha256
+ (base32
+ "1jvq4lj00hwml75lpmlciazy8f3bbg13gffsfnl835p4qd8l7yqv"))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-popup" ,emacs-popup)))
+ (home-page "https://github.com/auto-complete/auto-complete")
+ (synopsis "Intelligent auto-completion extension for Emacs")
+ (description
+ "Auto-Complete is an intelligent auto-completion extension for Emacs.
+It extends the standard Emacs completion interface and provides an environment
+that allows users to concentrate more on their own work. Its features are:
+a visual interface, reduce overhead of completion by using statistic method,
+extensibility.")
+ (license license:gpl3+)))