summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-08-05 19:34:43 +0200
committerDavid Craven <david@craven.ch>2016-08-28 14:04:55 +0200
commit81f1515d5ad5d8719b21a17fc610a6bf30bc456d (patch)
treed9da84523aed5270b6ed04e1a3b8a0ed7ac50755 /gnu
parentb2319996dc84dfcb3a87cdc1653f40c2e8de6502 (diff)
downloadguix-patches-81f1515d5ad5d8719b21a17fc610a6bf30bc456d.tar
guix-patches-81f1515d5ad5d8719b21a17fc610a6bf30bc456d.tar.gz
gnu: Add python-url.
* gnu/packages/python.scm (python-url): New variable. (python2-url): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d0832fff94..ee7ac2147c 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -10188,3 +10188,36 @@ List. Forked from and using the same API as the publicsuffix package.")
(native-inputs
`(("python2-setuptools" ,python2-setuptools)
,@(package-native-inputs base))))))
+
+(define-public python-url
+ (package
+ (name "python-url")
+ (version "0.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "url" version))
+ (sha256
+ (base32
+ "0v879yadcz9qxfl41ak6wkga1kimp9cflla9ddz03hjjvgkqy5ki"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-publicsuffix" ,python-publicsuffix)))
+ (native-inputs
+ `(("python-coverage" ,python-coverage)
+ ("python-nose" ,python-nose)))
+ (arguments
+ `(#:tests? #f)) ; FIXME: tests fail with "ImportError: No module named 'tests'"
+ (home-page "http://github.com/seomoz/url-py")
+ (synopsis "URL Parsing")
+ (description "Library for parsing urls.")
+ (license license:expat)
+ (properties `((python2-variant . ,(delay python2-url))))))
+
+(define-public python2-url
+ (let ((base (package-with-python2 (strip-python2-variant python-url))))
+ (package (inherit base)
+ (inputs
+ `(("python2-publicsuffix" ,python2-publicsuffix)))
+ (native-inputs
+ `(("python2-setuptools" ,python2-setuptools)
+ ,@(package-native-inputs base))))))