summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-08-28 23:25:53 +0000
committerAlex Kost <alezost@gmail.com>2016-08-31 10:10:30 +0300
commit41392b9a3d715daac76f92092323fdeb8cf8ad3a (patch)
treee9ee85398c0176b13f3c46ff29b1a8cab1c9084c /gnu
parent7d57ebaa7c4aefec69104fc10e56f04bceb6fe5b (diff)
downloadguix-patches-41392b9a3d715daac76f92092323fdeb8cf8ad3a.tar
guix-patches-41392b9a3d715daac76f92092323fdeb8cf8ad3a.tar.gz
gnu: Add emacs-flx.
* gnu/packages/emacs.scm (emacs-flx): New variable. Signed-off-by: Alex Kost <alezost@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 9a77d8ac0a..6485beef6b 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -3002,3 +3002,27 @@ lists, and project planning with a fast and effective plain-text system. It
also is an authoring system with unique support for literate programming and
reproducible research.")
(license license:gpl3+)))
+
+(define-public emacs-flx
+ (package
+ (name "emacs-flx")
+ (version "0.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/lewang/"
+ "flx/archive/v" version ".tar.gz"))
+ (sha256
+ (base32
+ "0bkcpnf1j4i2fcc2rllwbz62l00sw2mcia6rm5amgwvlkqavmkv6"))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/lewang/flx")
+ (synopsis "Fuzzy matching for Emacs")
+ (description
+ "Flx provides fuzzy matching for emacs a la sublime text.
+The sorting algorithm is a balance between word beginnings (abbreviation)
+and contiguous matches (substring). The longer the substring match,
+the higher it scores. This maps well to how we think about matching.
+Flx has support for ido (interactively do things) through flx-ido.")
+ (license license:gpl3+)))