summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-09-25 14:39:20 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-02 10:54:35 +0000
commit202749383546b990eb5d1cdf1a931ba374e8bfba (patch)
tree84ac9915c5066d68988cef6b3db5a6dda47b585d /gnu
parent7739273d9d70513f1371cf77790158ccd74b2ed1 (diff)
downloadguix-patches-202749383546b990eb5d1cdf1a931ba374e8bfba.tar
guix-patches-202749383546b990eb5d1cdf1a931ba374e8bfba.tar.gz
gnu: gnome-contacts: Update to 40.0.
* gnu/packages/gnome.scm (gnome-contacts): Update to 40.0. [source]: Fix the URI. [arguments]: Remove trailing #t. [native-inputs]: Add docbook-xml and docbook-xsl. [inputs]: Add libhandy.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 25e46014e8..c6df6cd910 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -2124,15 +2124,15 @@ commonly used macros.")
(define-public gnome-contacts
(package
(name "gnome-contacts")
- (version "3.38.1")
+ (version "40.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/gnome-contacts/"
- (version-major+minor version) "/"
+ (version-major version) "/"
name "-" version ".tar.xz"))
(sha256
(base32
- "0hsq0dwxjahcaxnm1m4r1lync9k2fkwzybfmkchrmn95vqcwwvf9"))))
+ "0w2g5xhw65adzvwzakrj5kaim4sw1w7s8qqwm3nm6inq50znzpn9"))))
(build-system meson-build-system)
(arguments
`(#:configure-flags '("-Dcheese=disabled")
@@ -2146,16 +2146,16 @@ commonly used macros.")
(invoke "vapigen" "--directory=vapi" "--pkg=gio-2.0"
"--library=goa-1.0"
- (string-append goa "/share/gir-1.0/Goa-1.0.gir"))
- #t))
+ (string-append goa "/share/gir-1.0/Goa-1.0.gir"))))
(add-after 'unpack 'skip-gtk-update-icon-cache
;; Don't create 'icon-theme.cache'.
(lambda _
(substitute* "build-aux/meson_post_install.py"
- (("gtk-update-icon-cache") "true"))
- #t)))))
+ (("gtk-update-icon-cache") "true")))))))
(native-inputs
- `(("glib:bin" ,glib "bin")
+ `(("docbook-xml" ,docbook-xml-4.2)
+ ("docbook-xsl" ,docbook-xsl)
+ ("glib:bin" ,glib "bin")
("pkg-config" ,pkg-config)))
(inputs
`(("docbook-xml" ,docbook-xml)
@@ -2168,6 +2168,7 @@ commonly used macros.")
("gst-plugins-base" ,gst-plugins-base)
("gtk+" ,gtk+)
("libgee" ,libgee)
+ ("libhandy" ,libhandy)
("libxslt" ,libxslt)
("telepathy-glib" ,telepathy-glib)
("vala" ,vala)))