summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNiklas Eklund <niklas.eklund@posteo.net>2020-11-20 17:45:38 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-11-21 22:06:38 +0100
commit908272c8953a9518b702c0a9dfffad3b3273546c (patch)
tree85808a623376a9ba60339a5ca7c8c900da26ace2 /gnu
parentc8535c252776ce7da3310c549d211df74f30559b (diff)
downloadguix-patches-908272c8953a9518b702c0a9dfffad3b3273546c.tar
guix-patches-908272c8953a9518b702c0a9dfffad3b3273546c.tar.gz
gnu: Add emacs-undo-fu.
* gnu/packages/emacs-xyz.scm (emacs-undo-fu): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 638b0da2e1..24c7973f17 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3048,6 +3048,32 @@ graphical tree presentation of all previous states of buffer that
allows easily move between them.")
(license license:gpl3+)))
+(define-public emacs-undo-fu
+ ;; There are no tagged releases upstream on gitlab, instead we are using
+ ;; the most recent commit.
+ (let ((commit "c0806c1903c5a0e4c69b6615cdc3366470a9b8ca")
+ (revision "0"))
+ (package
+ (name "emacs-undo-fu")
+ (version (git-version "0.4" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/ideasman42/emacs-undo-fu")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1n594aakmcgyl7qbda86v4wsx8clm62ypiv3h559xz3x72h7mr3j"))))
+ (build-system emacs-build-system)
+ (home-page "https://gitlab.com/ideasman42/emacs-undo-fu")
+ (synopsis "Simple, stable linear undo with redo for Emacs")
+ (description
+ "This is a light weight wrapper for Emacs built-in undo system,
+adding convenient undo/redo without losing access to the full undo history,
+allowing you to visit all previous states of the document if you need.")
+ (license license:gpl3+))))
+
(define-public emacs-s
(package
(name "emacs-s")