summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2020-12-06 16:56:16 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-12-07 11:40:47 +0100
commit65555198b2ad25c9754a48899cd4443441a310ef (patch)
tree7da95071788deb8d9af2df4ad4e47b3a41191b6d /gnu
parente461d3b750080b03f3deea0b44b99c2fda9767ab (diff)
downloadguix-patches-65555198b2ad25c9754a48899cd4443441a310ef.tar
guix-patches-65555198b2ad25c9754a48899cd4443441a310ef.tar.gz
gnu: emacs-with-editor: Update to 3.0.2.
* gnu/packages/emacs-xyz.scm (emacs-with-editor): Update to 3.0.2. [propagated-inputs]: Changed emacs-dash to emacs-async. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm62
1 files changed, 29 insertions, 33 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index de0b8e6103..7fd8f3c245 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -362,42 +362,38 @@ configuration files, such as .gitattributes, .gitignore, and .git/config.")
(license license:gpl3+)))
(define-public emacs-with-editor
- ;; This commit fixes an (magit) issue with emacs 28, see
- ;; https://lists.gnu.org/archive/html/help-gnu-emacs/2020-10/msg00211.html
- (let ((commit "c4768f51c7415119519b4626d8643d60e584098c")
- (revision "1"))
- (package
- (name "emacs-with-editor")
- (version (git-version "2.9.4" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/magit/with-editor")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "01ysb9pnscpmingay6njdywkqgj4hn5l5d9igsg3x7p7061jwwix"))))
- (build-system emacs-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'install 'make-info
- (lambda _
- (invoke "makeinfo" "--no-split"
- "-o" "with-editor.info" "with-editor.texi"))))))
- (native-inputs
- `(("texinfo" ,texinfo)))
- (propagated-inputs
- `(("emacs-dash" ,emacs-dash)))
- (home-page "https://github.com/magit/with-editor")
- (synopsis "Emacs library for using Emacsclient as EDITOR")
- (description
- "This package provides an Emacs library to use the Emacsclient as
+ (package
+ (name "emacs-with-editor")
+ (version "3.0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/magit/with-editor")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0hw6i5r3adkm4988badi94825lywkrh3sddiff4z04kj1nj15d0k"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'make-info
+ (lambda _
+ (invoke "makeinfo" "--no-split"
+ "-o" "with-editor.info" "with-editor.texi"))))))
+ (native-inputs
+ `(("texinfo" ,texinfo)))
+ (propagated-inputs
+ `(("emacs-async" ,emacs-async)))
+ (home-page "https://github.com/magit/with-editor")
+ (synopsis "Emacs library for using Emacsclient as EDITOR")
+ (description
+ "This package provides an Emacs library to use the Emacsclient as
@code{$EDITOR} of child processes, making sure they know how to call home.
For remote processes a substitute is provided, which communicates with Emacs
on stdout instead of using a socket as the Emacsclient does.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public emacs-libgit
(let ((commit "0ef8b13aef011a98b7da756e4f1ce3bb18e4d55a")