summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym+a@scratchpost.org>2016-06-07 08:27:10 +0200
committerLeo Famulari <leo@famulari.name>2016-06-07 13:27:50 -0400
commitd0b6fed6b85661a761df87ce9ceb0074603e9608 (patch)
tree0828696467c028b83bf5ba3edd02a3daf3ed611c /gnu
parent73c8d39c4bd5f57feeeb7fae8e3e00e3001b7400 (diff)
downloadguix-patches-d0b6fed6b85661a761df87ce9ceb0074603e9608.tar
guix-patches-d0b6fed6b85661a761df87ce9ceb0074603e9608.tar.gz
gnu: Add python-ply.
* gnu/packages/python.scm (python-ply, python2-ply): New variables. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index dfbf2cc916..143fc144b6 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -9009,3 +9009,31 @@ focus on event-based network programming and multiprotocol integration.")
(define-public python2-twisted
(package-with-python2 python-twisted))
+
+(define-public python-ply
+ (package
+ (name "python-ply")
+ (version "3.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/"
+ "96/e0/430fcdb6b3ef1ae534d231397bee7e9304be14a47a267e82ebcb3323d0b5"
+ "/ply-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1f70ipynmiy09k6px2j7v4w5cdrc21za3xs2k6f1bsvb0bzvvlg7"))))
+ (build-system python-build-system)
+ (home-page "http://www.dabeaz.com/ply/")
+ (synopsis "Python Lex & Yacc")
+ (description "PLY is a @code{lex}/@code{yacc} implemented purely in Python.
+It uses LR parsing and does extensive error checking.")
+ (license bsd-3)
+ (properties `((python2-variant . ,(delay python2-ply))))))
+
+(define-public python2-ply
+ (package
+ (inherit (package-with-python2
+ (strip-python2-variant python-ply)))
+ (native-inputs `(("python2-setuptools" ,python2-setuptools)))))