summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2022-01-11 10:50:53 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-01-11 10:50:53 +0100
commit732180015b86fe10fdbef4f3cc9a86285032f5c7 (patch)
treea70962765adfd05b03f1aa26e45ef120f722ca52 /gnu
parent69f8892860609ebd9f2db87e1df3cc52a6aa6c0b (diff)
downloadguix-patches-732180015b86fe10fdbef4f3cc9a86285032f5c7.tar
guix-patches-732180015b86fe10fdbef4f3cc9a86285032f5c7.tar.gz
gnu: Add python-pypdf3.
* gnu/packages/python-xyz.scm (python-pypdf3): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 68517d2292..6e4588b39d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -113,6 +113,7 @@
;;; Copyright © 2021 Raphaël Mélotte <raphael.melotte@mind.be>
;;; Copyright © 2021 ZmnSCPxj <ZmnSCPxj@protonmail.com>
;;; Copyright © 2021 Filip Lajszczak <filip@lajszczak.dev>
+;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -6915,6 +6916,27 @@ the OleFileIO module from PIL, the Python Image Library.")
(define-public python2-olefile
(package-with-python2 python-olefile))
+(define-public python-pypdf3
+ (package
+ (name "python-pypdf3")
+ (version "1.0.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "PyPDF3" version))
+ (sha256
+ (base32 "018hlq9q2qa96vw4j7ppq352znykldwy98h2w9qcpkvpi93sjqhc"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ (list python-tqdm))
+ (home-page "https://github.com/sfneal/PyPDF3")
+ (synopsis "Utility to read and write PDFs with Python")
+ (description "PyPDF3 is a pure-python PDF library capable of splitting,
+merging together, cropping, and transforming the pages of PDF files. It can
+also add custom data, viewing options, and passwords to PDF files. It can
+retrieve text and metadata from PDFs as well as merge entire files together.")
+ (license license:bsd-3)))
+
(define-public python-pikepdf
(package
(name "python-pikepdf")