summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-11 12:50:53 -0500
committerRaghav Gururajan <rg@raghavgururajan.name>2021-03-26 15:43:40 -0400
commit2f31302b78547ed8082d9d0a4d8108a4b53673ee (patch)
treed0257338acdda6f67760c1df8017d457ffd0d371 /gnu
parentda7d0c5ff0dd1b15805407e3493c547d35ed6697 (diff)
downloadguix-patches-2f31302b78547ed8082d9d0a4d8108a4b53673ee.tar
guix-patches-2f31302b78547ed8082d9d0a4d8108a4b53673ee.tar.gz
gnu: atkmm: Update to 2.36.0.
* gnu/packages/gtk.scm (atkmm) [version]: Update to 2.36.0. [build-system]: Change from gnu to meson. [arguments]<#:glib-or-gtk?>: New argument. [native-inputs]: Add m4, mm-common, perl and libxslt. Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gtk.scm28
1 files changed, 18 insertions, 10 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index a85feb87e4..b3498fa525 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -78,6 +78,7 @@
#:use-module (gnu packages image)
#:use-module (gnu packages libffi)
#:use-module (gnu packages linux)
+ #:use-module (gnu packages m4)
#:use-module (gnu packages man)
#:use-module (gnu packages pdf)
#:use-module (gnu packages perl)
@@ -1437,17 +1438,24 @@ library.")
(define-public atkmm
(package
(name "atkmm")
- (version "2.28.0")
+ (version "2.36.0")
(source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnome/sources/" name "/"
- (version-major+minor version) "/"
- name "-" version ".tar.xz"))
- (sha256
- (base32
- "0fnxrspxkhhbrjphqrpvl3zjm66n50s4cywrrrwkhbflgy8zqk2c"))))
- (build-system gnu-build-system)
- (native-inputs `(("pkg-config" ,pkg-config)))
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0wwr0663jrqx2klsasffd9wpk3kqnwisj1y3ahdkjdk5hzrsjgy9"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:glib-or-gtk? #t)) ; To wrap binaries and/or compile schemas
+ (native-inputs
+ `(("m4" ,m4)
+ ("mm-common" ,mm-common)
+ ("perl" ,perl)
+ ("pkg-config" ,pkg-config)
+ ("xsltproc" ,libxslt)))
(propagated-inputs
`(("glibmm" ,glibmm) ("atk" ,atk)))
(home-page "https://www.gtkmm.org")