summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-06-25 12:03:45 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-06-26 16:24:58 +0200
commit37c173d162e0d16d837c39cc788f12e040521d0b (patch)
treef29d0252d22c999f4c756d453e36648a80240dbf /gnu
parent05b3dcbe32cdf62bbe5d04d16297bcd38d0d7377 (diff)
downloadguix-patches-37c173d162e0d16d837c39cc788f12e040521d0b.tar
guix-patches-37c173d162e0d16d837c39cc788f12e040521d0b.tar.gz
gnu: Add python-jaraco-packaging.
* gnu/packages/python-xyz.scm (python-jaraco-packaging): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index daf327b971..e2a3d71b38 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4884,6 +4884,34 @@ its top-level name. This functionality intends to replace most uses of
need to use the older and less efficient @code{pkg_resources} package.")
(license license:asl2.0)))
+(define-public python-jaraco-packaging
+ (package
+ (name "python-jaraco-packaging")
+ (version "6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "jaraco.packaging" version))
+ (sha256
+ (base32
+ "0zimrnkh33b9g8ffw11mjh6kvs54cy5gcjw1h5cl1r7dc833dmkm"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-pytest-checkdocs" ,python-pytest-checkdocs)
+ ("python-pytest-flake8" ,python-pytest-flake8)
+ ("python-rst.linker" ,python-rst.linker)
+ ("python-setuptools" ,python-setuptools)
+ ("python-setuptools-scm" ,python-setuptools-scm)
+ ("python-six" ,python-six)
+ ("python-sphinx" ,python-sphinx)))
+ (home-page "https://github.com/jaraco/jaraco.packaging")
+ (synopsis "Tools to supplement packaging Python releases")
+ (description
+ "This package provides various tools to supplement packaging Python
+releases.")
+ (license license:expat)))
+
(define-public python-pathpy
(package
(name "python-pathpy")