summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-06-20 08:57:41 +0900
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2019-06-26 11:08:45 +0900
commit2fdfa195a6ba0048c6e1d5d8800971a2121e9eb1 (patch)
tree456515daf38c8ffba77efeece5f363b3fbc3e680 /gnu
parentdae2eb1c127c636226ba11d05ec638f113a3c831 (diff)
downloadguix-patches-2fdfa195a6ba0048c6e1d5d8800971a2121e9eb1.tar
guix-patches-2fdfa195a6ba0048c6e1d5d8800971a2121e9eb1.tar.gz
gnu: Add emacs-ascii-art-to-unicode.
* gnu/packages/emacs-xyz.scm (emacs-ascii-art-to-unicode): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 61fa8c2f81..205a4c8e0c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9678,6 +9678,27 @@ matches\" in the mode line in various search modes. This is an Emacs port of
Anzu.zim.")
(license license:gpl3+)))
+(define-public emacs-ascii-art-to-unicode
+ (package
+ (name "emacs-ascii-art-to-unicode")
+ (version "1.12")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://elpa.gnu.org/packages/ascii-art-to-unicode-"
+ version ".el"))
+ (sha256
+ (base32
+ "1w9h2lyriafxj71r79774gh822cz8mry3gdfzyj6ym6v9mvqypna"))))
+ (build-system emacs-build-system)
+ (home-page "https://elpa.gnu.org/packages/ascii-art-to-unicode.html")
+ (synopsis "ASCII to Unicode art converter for Emacs")
+ (description "This Emacs package provides the commands @command{aa2u} and
+@command{aa2u-rectangle}. Both of these commands can be used to convert
+simple ASCII art line drawings to Unicode; the former works on the active
+region of the buffer, while the latter works on rectangular selections.")
+ (license license:gpl3+)))
+
(define-public emacs-emmet-mode
(package
(name "emacs-emmet-mode")