summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-11-07 14:15:28 +0000
committerEfraim Flashner <efraim@flashner.co.il>2021-11-07 22:28:46 +0200
commitb76b29957ebb059a9b39075218726293ac24f3b1 (patch)
tree08efbaa2124c4198c9bab105e4bae1d50f9e37ae /gnu
parente9eb6b1102061dd987d85ed9a76449e4dc44ff7c (diff)
downloadguix-patches-b76b29957ebb059a9b39075218726293ac24f3b1.tar
guix-patches-b76b29957ebb059a9b39075218726293ac24f3b1.tar.gz
gnu: Add rust-log-mdc-0.1.
* gnu/packages/crates-io.scm (rust-log-mdc-0.1): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 1853409b61..a73f7e9f60 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -26960,6 +26960,25 @@ by inspecting the system for user preference.")
`(#:cargo-inputs
(("rust-log" ,rust-log-0.4))))))
+(define-public rust-log-mdc-0.1
+ (package
+ (name "rust-log-mdc")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "log-mdc" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1iw1x3qhjvrac35spikn5h06a1rxd9vw216jk8h52jhz9i0j2kd9"))))
+ (build-system cargo-build-system)
+ (home-page "https://github.com/sfackler/rust-log-mdc")
+ (synopsis "Mapped diagnostic context (MDC) for use with the `log` crate")
+ (description "This package provides a mapped diagnostic context (MDC) for
+use with the `log` crate.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-logtest-2
(package
(name "rust-logtest")