summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAdonay Felipe Nogueira <adfeno@openmailbox.org>2017-01-14 16:42:05 -0200
committerAlex Kost <alezost@gmail.com>2017-02-03 22:50:20 +0300
commitefc12a81ad399acd93b223bca46a3c0d739e082a (patch)
tree30ee4565def8f4b75cce39dc8e6b5e019a553f25 /gnu
parentc6dced88f262f7e781288f32cc3a376b929a6214 (diff)
downloadguix-patches-efc12a81ad399acd93b223bca46a3c0d739e082a.tar
guix-patches-efc12a81ad399acd93b223bca46a3c0d739e082a.tar.gz
gnu: abbaye: Update to 2.0.1.
* gnu/packages/games.scm: (abbaye): Update to 2.0.1. [snippet]: Delete the bundled fonts. [arguments]: Adjust 'patch-makefile' phase to patch only Makefile. Add "CC" make flag. [inputs]: Use only required sdl2 packages. [home-page]: Update to the new location. [license]: Use the proper license. Signed-off-by: Alex Kost <alezost@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm32
1 files changed, 16 insertions, 16 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index c3514feaca..0867089d5a 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2016 Steve Webber <webber.sl@gmail.com>
+;;; Copyright © 2017 Adonay "adfeno" Felipe Nogueira <https://libreplanet.org/wiki/User:Adfeno> <adfeno@openmailbox.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -177,22 +178,23 @@ scriptable with Guile.")
(define-public abbaye
(package
(name "abbaye")
- (version "1.13")
+ (version "2.0.1")
(source
(origin
(method url-fetch)
- (uri (string-append "https://storage.googleapis.com/"
- "google-code-archive-downloads/v2/code.google.com/"
- "abbaye-for-linux/abbaye-for-linux-src-"
- version ".tar.gz"))
+ (uri (string-append "https://github.com/nevat/abbayedesmorts-gpl/"
+ "archive/v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1wgvckgqa2084rbskxif58wbb83xbas8s1i8s7d57xbj08ryq8rk"))))
+ "1a67b0hq6271dd7pvwndjq29cwn2n8gawwz17xafa3k1hrhf8vw3"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; Unbundle fonts.
+ '(delete-file-recursively "fonts"))))
(build-system gnu-build-system)
(arguments
- '(#:modules ((ice-9 match)
- (guix build gnu-build-system)
- (guix build utils))
+ '(#:make-flags '("CC=gcc")
#:phases (modify-phases %standard-phases
(add-after 'set-paths 'set-sdl-paths
(lambda* (#:key inputs #:allow-other-keys)
@@ -202,10 +204,8 @@ scriptable with Guile.")
(add-after 'patch-source-shebangs 'patch-makefile
(lambda* (#:key outputs #:allow-other-keys)
;; Replace /usr with package output directory.
- (for-each (lambda (file)
- (substitute* file
- (("/usr") (assoc-ref outputs "out"))))
- '("makefile" "src/pantallas.c" "src/comun.h"))))
+ (substitute* "Makefile"
+ (("/usr") (assoc-ref outputs "out")))))
(add-before 'install 'make-install-dirs
(lambda* (#:key outputs #:allow-other-keys)
(let ((prefix (assoc-ref outputs "out")))
@@ -217,15 +217,15 @@ scriptable with Guile.")
(delete 'configure))
#:tests? #f)) ;; No check target.
(native-inputs `(("pkg-config" ,pkg-config)))
- (inputs `(("sdl-union" ,(sdl-union))))
- (home-page "http://code.google.com/p/abbaye-for-linux/")
+ (inputs `(("sdl-union" ,(sdl-union (list sdl2 sdl2-image sdl2-mixer)))))
+ (home-page "https://github.com/nevat/abbayedesmorts-gpl")
(synopsis "GNU/Linux port of the indie game \"l'Abbaye des Morts\"")
(description "L'Abbaye des Morts is a 2D platform game set in 13th century
France. The Cathars, who preach about good Christian beliefs, were being
expelled by the Catholic Church out of the Languedoc region in France. One of
them, called Jean Raymond, found an old church in which to hide, not knowing
that beneath its ruins lay buried an ancient evil.")
- (license license:gpl3+)))
+ (license license:gpl3)))
(define-public pingus
(package