summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRaoul Jean Pierre Bonnal <ilpuccio.febo@gmail.com>2017-01-14 01:52:09 +0100
committerKei Kebreau <kei@openmailbox.org>2017-02-03 14:21:22 -0500
commitc6dced88f262f7e781288f32cc3a376b929a6214 (patch)
treefbe35843318fcecc72502f84bf4c886dee54afa9 /gnu
parent37337699d7d6069ccd38aae6cc25bdbf4a6e56fc (diff)
downloadguix-patches-c6dced88f262f7e781288f32cc3a376b929a6214.tar
guix-patches-c6dced88f262f7e781288f32cc3a376b929a6214.tar.gz
gnu: Add r-rann.
* gnu/packages/statistics.scm (r-rann): New variable. Signed-off-by: Kei Kebreau <kei@openmailbox.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/statistics.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 80f0b99b86..b4d95bdb71 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -4006,6 +4006,27 @@ dispersion modeling and Tweedie power-law families.")
;; Statmod is distributed under either license
(license (list license:gpl2 license:gpl3))))
+(define-public r-rann
+ (package
+ (name "r-rann")
+ (version "2.5")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "RANN" version))
+ (sha256
+ (base32
+ "007cgqg9bybg2zlljbv5m6cmlm3r6i251018rpgjcn0xnm9sjsj7"))))
+ (properties
+ `((upstream-name . "RANN")))
+ (build-system r-build-system)
+ (home-page "https://github.com/jefferis/RANN")
+ (synopsis "Fast nearest neighbour search")
+ (description
+ "This package finds the k nearest neighbours for every point in a given
+dataset in O(N log N) time using Arya and Mount's ANN library. Provides
+approximate, exact searches, fixed radius searches, bd and kb trees.")
+ (license license:gpl3+)))
+
(define-public r-fivethirtyeight
(package
(name "r-fivethirtyeight")