summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-08-28 15:51:34 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-08-28 16:53:04 +0300
commit36bd543afc4d248093f1f07c150a5031fcec70f8 (patch)
treeb5c37fd1cab1c526e2f9a0bdc1bd4f2e085ed4cb /gnu
parentf8f4025ae53e671f283ec32a840197702a797e6a (diff)
downloadguix-patches-36bd543afc4d248093f1f07c150a5031fcec70f8.tar
guix-patches-36bd543afc4d248093f1f07c150a5031fcec70f8.tar.gz
gnu: Add rust-foreign-types-shared.
* gnu/packages/crates-io.scm (rust-foreign-types-shared): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index bba0f8fc49..c2af57eb90 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -418,6 +418,26 @@ implementation that is more efficient for smaller hash keys.")
(license (list license:asl2.0
license:expat))))
+(define-public rust-foreign-types-shared
+ (package
+ (name "rust-foreign-types-shared")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "foreign-types-shared" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0kanxlif1vp0ffh2r9l610jqbkmb3183yqykxq1z5w1vay2rn7y6"))))
+ (build-system cargo-build-system)
+ (home-page "https://github.com/sfackler/foreign-types")
+ (synopsis "An internal crate used by foreign-types")
+ (description
+ "An internal crate used by foreign-types.")
+ (license (list license:asl2.0
+ license:expat))))
+
(define-public rust-fs-extra
(package
(name "rust-fs-extra")