summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-11-29 14:58:39 +0100
committerMathieu Othacehe <othacehe@gnu.org>2021-11-29 14:58:39 +0100
commitf22dfba53032c59fb260173143abf0e4e9a4f1e1 (patch)
tree1a40a2db3da9c51dcd5f1c273acddf029a7294ab /gnu
parent3d54f2415672aed64661bed84a043a7f0cee13dd (diff)
downloadguix-patches-f22dfba53032c59fb260173143abf0e4e9a4f1e1.tar
guix-patches-f22dfba53032c59fb260173143abf0e4e9a4f1e1.tar.gz
gnu: agg: Fix build.
* gnu/packages/patches/agg-2.5-gcc8.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/graphics.scm (agg)[source]: Use it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/graphics.scm3
-rw-r--r--gnu/packages/patches/agg-2.5-gcc8.patch14
3 files changed, 17 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 106326972d..604c6cf151 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -836,6 +836,7 @@ dist_patch_DATA = \
%D%/packages/patches/aegisub-boost68.patch \
%D%/packages/patches/aegisub-make43.patch \
%D%/packages/patches/agg-am_c_prototype.patch \
+ %D%/packages/patches/agg-2.5-gcc8.patch \
%D%/packages/patches/akonadi-paths.patch \
%D%/packages/patches/akonadi-not-relocatable.patch \
%D%/packages/patches/akonadi-timestamps.patch \
diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 1c78bd7d5e..99b4010e76 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -1539,7 +1539,8 @@ and understanding different BRDFs (and other component functions).")
version ".tar.gz")))
(sha256
(base32 "07wii4i824vy9qsvjsgqxppgqmfdxq0xa87i5yk53fijriadq7mb"))
- (patches (search-patches "agg-am_c_prototype.patch"))))
+ (patches (search-patches "agg-am_c_prototype.patch"
+ "agg-2.5-gcc8.patch"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags
diff --git a/gnu/packages/patches/agg-2.5-gcc8.patch b/gnu/packages/patches/agg-2.5-gcc8.patch
new file mode 100644
index 0000000000..dfcfc6cd4a
--- /dev/null
+++ b/gnu/packages/patches/agg-2.5-gcc8.patch
@@ -0,0 +1,14 @@
+Taken from: https://gitweb.gentoo.org/repo/gentoo.git/tree/x11-libs/agg/files/agg-2.5-gcc8.patch.
+
+diff -uprN agg-2.5/include/agg_renderer_outline_aa.h agg-2.5-fixed/include/agg_renderer_outline_aa.h
+--- agg-2.5/include/agg_renderer_outline_aa.h 2018-08-25 02:02:52.507254241 +0800
++++ agg-2.5-fixed/include/agg_renderer_outline_aa.h 2018-08-25 02:04:15.291175316 +0800
+@@ -1375,7 +1375,7 @@ namespace agg
+ //---------------------------------------------------------------------
+ void profile(const line_profile_aa& prof) { m_profile = &prof; }
+ const line_profile_aa& profile() const { return *m_profile; }
+- line_profile_aa& profile() { return *m_profile; }
++ const line_profile_aa& profile() { return *m_profile; }
+
+ //---------------------------------------------------------------------
+ int subpixel_width() const { return m_profile->subpixel_width(); }