summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-12-07 22:47:40 +0100
committerAndreas Enge <andreas@enge.fr>2013-12-07 22:47:40 +0100
commite426106bd1a67f9ac8a1a1b52a51968b7944422f (patch)
treedda34a9d8bc141d04513c45aa8a8d454b0b3ad7b /gnu
parent24b3c0533d600d157bf9ec1cd0f5cf78a47348a3 (diff)
downloadguix-patches-e426106bd1a67f9ac8a1a1b52a51968b7944422f.tar
guix-patches-e426106bd1a67f9ac8a1a1b52a51968b7944422f.tar.gz
gnu: Add perl-io-html.
* gnu/packages/web.scm (perl-io-html): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 2ed9d5e2d0..905b854d6a 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -172,3 +172,24 @@ known as MIME) types and encodings. The mapping from file extensions to
media types is defined by the media.types file. If the ~/.media.types file
exists it is used instead.")
(home-page "http://search.cpan.org/~gaas/LWP-MediaTypes/")))
+
+(define-public perl-io-html
+ (package
+ (name "perl-io-html")
+ (version "1.00")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/C/CJ/CJM/IO-HTML-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "06nj3a0xgp5jxwxx6ayglfk2v7npf5a7gwkqsjlkapjkybarzqh4"))))
+ (build-system perl-build-system)
+ (license (package-license perl))
+ (synopsis "Perl module to open an HTML file with automatic charset detection")
+ (description
+ "IO::HTML provides an easy way to open a file containing HTML while
+automatically determining its encoding. It uses the HTML5 encoding sniffing
+algorithm specified in section 8.2.2.1 of the draft standard.")
+ (home-page "http://search.cpan.org/~cjm/IO-HTML/")))