summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-11 11:20:37 -0500
committerRaghav Gururajan <rg@raghavgururajan.name>2021-03-26 15:43:38 -0400
commitae480633cfdacfc87c8a35cb585d506654926784 (patch)
tree075496a2fcac97d67ec4bdac8a29bafdcf0a8bf7 /gnu
parentb1ab7a5a33f2940e2e401d80783345eb2ae643b2 (diff)
downloadguix-patches-ae480633cfdacfc87c8a35cb585d506654926784.tar
guix-patches-ae480633cfdacfc87c8a35cb585d506654926784.tar.gz
gnu: vala: Change build-system.
* gnu/packages/gnome.scm (vala) [build-system]: Change from gnu to glib-or-gtk. Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index c69fb21ba5..bbc82cfcd1 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4279,28 +4279,28 @@ passwords in the GNOME keyring.")
(sha256
(base32
"1nx5xjarpkl9hgy0qbqfczx7d7clh5g1r8xr5xp8b97c5fsc2rb1"))))
- (build-system gnu-build-system)
+ (build-system glib-or-gtk-build-system)
(arguments
'(#:phases
(modify-phases %standard-phases
(add-before 'check 'pre-check
- (lambda _
- (setenv "CC" "gcc")
- (substitute* "valadoc/tests/libvaladoc\
+ (lambda _
+ (setenv "CC" "gcc")
+ (substitute* "valadoc/tests/libvaladoc\
/tests-extra-environment.sh"
- (("export PKG_CONFIG_PATH=" m)
- (string-append m "$PKG_CONFIG_PATH:"))))))))
+ (("export PKG_CONFIG_PATH=" m)
+ (string-append m "$PKG_CONFIG_PATH:"))))))))
(native-inputs
`(("pkg-config" ,pkg-config)
("flex" ,flex)
("bison" ,bison)
("xsltproc" ,libxslt)
- ("dbus" ,dbus) ; for dbus tests
+ ("dbus" ,dbus) ; for dbus tests
("gobject-introspection" ,gobject-introspection))) ; for gir tests
(inputs
`(("graphviz" ,graphviz)))
(propagated-inputs
- `(("glib" ,glib))) ; required by libvala-0.40.pc
+ `(("glib" ,glib))) ; required by libvala-0.40.pc
(home-page "https://wiki.gnome.org/Projects/Vala/")
(synopsis "Compiler for the GObject type system")
(description