summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-25 06:49:16 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-03-26 15:27:21 -0400
commita1b965f8827a93a9a7de1472fa9c137dfce03fe1 (patch)
treeeb3e24d926c3719c798a25af67161eeddd19da4a /gnu
parentdfa9cea3505b8b6a72a9cf2bdbbabef300ee5d5e (diff)
downloadguix-patches-a1b965f8827a93a9a7de1472fa9c137dfce03fe1.tar
guix-patches-a1b965f8827a93a9a7de1472fa9c137dfce03fe1.tar.gz
gnu: cairomm: Update to 1.16.0.
* gnu/packages/gtk.scm (cairomm)[version]: Update to 1.16.0. [build-system]: Change from gnu to meson. [arguments]<#:glib-or-gtk?>: New argument. <#:configure-flags>[-Dboost-shared]: New flag. <#:make-flags>: Remove argument. [native-inputs]: Add boost and mm-common. Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gtk.scm20
1 files changed, 13 insertions, 7 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 92a6dfc723..82d59ed60b 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -58,6 +58,7 @@
#:use-module (gnu packages algebra)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
+ #:use-module (gnu packages boost)
#:use-module (gnu packages build-tools)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages check)
@@ -1264,19 +1265,24 @@ guile-gnome-platform (GNOME developer libraries), and guile-gtksourceview.")
(define-public cairomm
(package
(name "cairomm")
- (version "1.12.2")
+ (version "1.16.0")
(source (origin
(method url-fetch)
(uri (string-append "https://www.cairographics.org/releases/"
- name "-" version ".tar.gz"))
+ name "-" version ".tar.xz"))
(sha256
(base32
- "16fmigxsaz85c3lgcls7biwyz8zy8c8h3jndfm54cxxas3a7zi25"))))
- (build-system gnu-build-system)
+ "1ya4y7qa000cjawqwswbqv26y5icfkmhs5iiiil4dxgrqn91923y"))))
+ (build-system meson-build-system)
(arguments
- ;; The examples lack -lcairo.
- '(#:make-flags '("LDFLAGS=-lcairo")))
- (native-inputs `(("pkg-config" ,pkg-config)))
+ `(#:glib-or-gtk? #t ; To wrap binaries and/or compile schemas
+ #:configure-flags
+ (list
+ "-Dboost-shared=true")))
+ (native-inputs
+ `(("boost" ,boost)
+ ("mm-common" ,mm-common)
+ ("pkg-config" ,pkg-config)))
(propagated-inputs
`(("libsigc++" ,libsigc++)
("freetype" ,freetype)