summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-26 10:42:00 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-03-26 16:35:03 -0400
commit9c62b78f52983f705121b52796c2735d167a57e0 (patch)
treeb3ecf57be8342a6d883689200d8ff6a130372ced /gnu
parentce469cf96d89cd3be5e1eb36a29f6788fa13c5ed (diff)
downloadguix-patches-9c62b78f52983f705121b52796c2735d167a57e0.tar
guix-patches-9c62b78f52983f705121b52796c2735d167a57e0.tar.gz
gnu: wayland: Fix and move documentation.
* gnu/packages/freedesktop.scm (wayland) [outputs]: New output "doc". [arguments]<#:phases>['patch-docbook-xml]: New phase. ['move-doc]: New phase. Signed-off-by: Léo Le Bouter <lle-bout@zaclys.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/freedesktop.scm25
1 files changed, 24 insertions, 1 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index d5e58730e2..af581f32eb 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -925,8 +925,31 @@ Python.")
(base32
"05bd2vphyx8qwa1mhsj1zdaiv4m4v94wrlssrn0lad8d601dkk5s"))))
(build-system meson-build-system)
+ (outputs '("out" "doc"))
(arguments
- `(#:parallel-tests? #f))
+ `(#:parallel-tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-docbook-xml
+ (lambda* (#:key inputs #:allow-other-keys)
+ (with-directory-excursion "doc"
+ (substitute* (find-files "." "\\.xml$")
+ (("http://www.oasis-open.org/docbook/xml/4\\.5/")
+ (string-append (assoc-ref inputs "docbook-xml")
+ "/xml/dtd/docbook/"))
+ (("http://www.oasis-open.org/docbook/xml/4\\.2/")
+ (string-append (assoc-ref inputs "docbook-xml-4.2")
+ "/xml/dtd/docbook/"))))
+ #t))
+ (add-after 'install 'move-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (assoc-ref outputs "doc")))
+ (mkdir-p (string-append doc "/share"))
+ (rename-file
+ (string-append out "/share/doc")
+ (string-append doc "/share/doc"))
+ #t))))))
(native-inputs
`(("docbook-xml-4.2" ,docbook-xml-4.2)
("docbook-xml" ,docbook-xml)