summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorOlivier Dion <olivier.dion@polymtl.ca>2021-10-25 12:18:43 -0400
committerLudovic Courtès <ludo@gnu.org>2021-10-28 00:44:10 +0200
commit9b0ee18ba8b2c2cdc5238cbaa2fb2648d55b30c9 (patch)
tree667af833fdef524686fcbe0f06a7404361a927dc /gnu
parentb19250eec6f92308f237a09a43e8e3e2355345b9 (diff)
downloadguix-patches-9b0ee18ba8b2c2cdc5238cbaa2fb2648d55b30c9.tar
guix-patches-9b0ee18ba8b2c2cdc5238cbaa2fb2648d55b30c9.tar.gz
gnu: lttng-tools: Patch default man path.
* gnu/packages/linux.scm (lttng-tools) [arguments]: Add 'patch-default-man-path after 'unpack phase. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 61ec6d8657..3b4da16d78 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -8167,7 +8167,12 @@ to ring buffers shared with a consumer daemon.")
(add-before 'configure 'set-environment-variables
(lambda _
(setenv "HOME" "/tmp")
- (setenv "LTTNG_HOME" "/tmp"))))))
+ (setenv "LTTNG_HOME" "/tmp")))
+ ;; We don't put (which "man") here because LTTng uses execlp.
+ (add-after 'unpack 'patch-default-man-path
+ (lambda _
+ (substitute* "src/common/defaults.h"
+ (("/usr/bin/man") "man")))))))
;; NOTE - Users have to install python-3 in their profile to use the
;; bindings. We don't put it in the inputs, because the rest of the tools
;; can work without it.